Notifications
Clear all

wpForo 1.x.x Problems with translations

6 Posts
3 Users
0 Likes
679 Views
madshardie@gmail.com
Posts: 8
Topic starter
(@madshardiegmail-com)
Active Member
Joined: 3 years ago

Hi. 

A week ago i translated some of Wpforo, but client want's more to be translated. So I downloaded the wpforo-da_DK.po, which was already modified once and opened it in Poedit again and did some more translations. Problem is, that those translations I just did seems to work fine, but the ones I did at the first time a week ago, are now back to default.

What to do?

Thank you.

5 Replies
Robert
Posts: 9267
Admin
(@robert)
Support Team
Joined: 6 years ago

That's incorrect way to translate. You should use either wpForo Phrases System or Loco Translate Plugin.

More info in Documentation:  https://wpforo.com/docs/root/translation/how-to-translate/

Reply
3 Replies
madshardie@gmail.com
(@madshardiegmail-com)
Joined: 3 years ago

Active Member
Posts: 8

@robert

Thank you.

I'm not sure why it is the wrong way? I followed this explanation https://cl.ly/5163ae. 

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9267

@madshardiegmail-com

Plugin folder is being updated every time you update it, so all changes in /wpf-languages/ directory will be lost. It's obvious. If you translate PO/MO files, you should send it to us, so we could add in core. This way you'll get those files in wpForo even after the update. However the best ways to translate are the options I mentioned in my previous reply. So, please just use those options.

Reply
madshardie@gmail.com
(@madshardiegmail-com)
Joined: 3 years ago

Active Member
Posts: 8

@robert

Thank you for explanation. Will it also be lost, when I use a Child theme?

Thank you for helping me out! 

Reply
jodeci2008
Posts: 1
(@jodeci2008)
New Member
Joined: 2 years ago

Hi Robert,

I'm using Loco translate on my website, but somehow not all words are translated to French for WPforo, can you tell me how to get loco translate to translate all the words in wpforo?

Thanks!

 

Reply
Share: