Notifications
Clear all

Register Forum Doesn't Submit - Returns To Sign Up Page

25 Posts
3 Users
1 Likes
331 Views
therkf
Posts: 15
Topic starter
(@therkf)
Active Member
Joined: 2 months ago

Using a fresh install of 2.0.5. Simple setup, mostly working well.

Existing WP users can create posts, but new users cannot register.

  1. From the Register link, user enters a username and email address, and checked the "not a robot" recaptcha box & email confirmation.
  2. Clicking the Register button simply causes the same page to load. with a redirect parameter added to the URL.

We are running Litespeed, but I have excluded all the wpForo pages in the cache settings. (I've also tried disabling the cache completely.) Cloudflare is in dev mode after a full purge.

I've tried going to General Settings and resaved the URLs.

Any suggestions?

Thanks!

24 Replies
dimalifragis
Posts: 1638
(@dimalifragis)
Noble Member
Joined: 2 years ago

Please post a url if you want and can. If you do not want to publicly post a url, use a temporary url web service, so your url will dissapear after a while.

Reply
therkf
Posts: 15
Topic starter
(@therkf)
Active Member
Joined: 2 months ago
Reply
4 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9713

@therkf,

Let's start by excluding forum page from LiteSpeed Cache plugin.

  1. Please navigate in Dashboard to LiteSpeed Cache > Cache admin page
  2. Go to Exclude Tab, find the "Do Not Cache URIs" option
  3. Insert the URL path(s) of your forum page(s) one per line in the option textarea: /forum/
  4. Save it and delete all caches.
Reply
therkf
(@therkf)
Joined: 2 months ago

Active Member
Posts: 15

@robert thank you, but I have already excluded forum pages from the cache.

Reply
dimalifragis
(@dimalifragis)
Joined: 2 years ago

Noble Member
Posts: 1638

@therkf Check your html source bottom, and see the "Supported by" notice. Not sure what "supported" means, maybe it means not cached but optimized?

But it should say "UNcached".

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9713

@therkf,

I see it's not excluded yet.

 

Please leave a screenshot of the LiteSpeed Cache > Cache admin page where it's excluded. Which option have you used? Also, please make sure you've fully purged all caches.

Reply
therkf
Posts: 15
Topic starter
(@therkf)
Active Member
Joined: 2 months ago

That's really interesting, as LS Cache has been disabled since before the original post in this thread.

Here are the excludes. (sorry, tried to pass an image, no go - see attachments) 

Also, prior to the original post, I had put Cloudflare in Dev mode.

 

So here's the latest:

  1. With LS Cache disabled, the code says "supported by"
  2. With LS Cache enabled, but the forum pages excluded, the code says "UNcached"
  3. With LS Cache enabled and the page not excluded, code says "generated by"

Even in the ideal scenario, when LS Cache is saying uncached, the reg page still just reloads itself.

Thanks for all the help so far!

Reply
therkf
Posts: 15
Topic starter
(@therkf)
Active Member
Joined: 2 months ago

Cache disabled

Reply
Page 1 / 3
Share: