Notifications
Clear all

wpForo 1.x.x [Solved] Registration email FROM address is wordpress@mydomain.com

9 Posts
6 Users
2 Likes
5,940 Views
ginda
Posts: 1
Topic starter
(@ginda)
New Member
Joined: 4 years ago

I have set our email address in

Forums - Settings - Emails (From email address: info@mydomain.com)

But whenever someone registers for the forum the recieve an email from wordpress@mydomain.com instead of info@mydomain.com. How can I fix this?

Thanks in advance

Topic Tags
8 Replies
Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 6 years ago

This has nothing to do with wpForo. All registrations and emails are handled by Wordpress. No one Registers to the Forums, they register to Wordpress script.

This is a well known issue for WP, search to find the solution.

 

Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi  ginda,

The email address that you fill in mail  Forums > Settings > Emails don't have any relation to registration email. This email address related to all email notifications, that you see in Forums > Settings > Emails tab. The registration notifications send to the email address, that you field in  Dashboard > Settings > General > Email Address option admin page. 

Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 6 years ago
Posted by: Sofy

The registration notifications send to the email address, that you field in  Dashboard > Settings > General > Email Address option admin page. 

 

Sorry but Nope.

Robert
Posts: 9265
Admin
(@robert)
Support Team
Joined: 6 years ago

@ginda,

All emails (excerpt user registration) related to forum are being sent from the EMail you configured in the Forums > Settings > Emails admin page. User registration process is under WordPress control, not wpForo. wpForo only provides with registration form, other processes are performed by WordPress. And yes, this is a known issue of WordPress. This is the default Wordpress email. You should change it using some hooks like this:

add_filter( 'wp_mail_from', function( $name ) {return 'info@mydomain.com' ; } ) ;
add_filter( 'wp_mail_from_name', function( $name ) {return 'My Forum name' ; } ) ;

Change the red marked strings and put this code in your current active theme functions.php file. Make sure you didn't deleted the apostrophe before and after the strings.

More info about this issue: http://www.wpbeginner.com/plugins/how-to-change-sender-name-in-outgoing-wordpress-email/

 

 

3 Replies
Iris
 Iris
(@iris)
Joined: 2 years ago

New Member
Posts: 1

@robert Hello, I changed both (sender and email, now I'm using a corporate email) but the email is still dropping at spam folder... what do you think is the problem now? maybe the text?

thanks in advance!

 

Anonymous20
(@anonymous20)
Joined: 6 years ago

Noble Member
Posts: 1602
Posted by: @iris

@robert Hello, I changed both (sender and email, now I'm using a corporate email) but the email is still dropping at spam folder... what do you think is the problem now? maybe the text?

thanks in advance!

 

All email functions are handled by Wordpress core and not wpForo. So if your email (out) from Wordpress is considered as spam, it is an email server problem or setup, or your mail server is flagged as sending spam out, or something else. Nothing to fdo with wpForo.

In the HEADER of the email usually you can see the "why".

 

Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9265

@iris,

I'm sorry, but there is no any "next". This means your hosting server IP address and your domain is in black list of email servers or it's very untrusted. wpForo has nothing to do with this issue, you should read articles and find why your emails go to spam. Here are some good articles:

 

Page 1 / 2
Share: