Notifications
Clear all

Script [Solved] Stop server looking for 'discussions that may have what you're looking for'

11 Posts
3 Users
6 Likes
511 Views
Posts: 94
Topic starter
(@vanessa)
Estimable Member
Joined: 6 months ago

Is there a way to stop the server from doing work as a user types the title to try and show the dialog that shows 'discussions that may have what you're looking for' that shows up as a user enters a title?

 

I know I can hide it by setting

.wpf-suggested-topics-list {
display: none!important;
}

 

But I'd like to avoid the server doing any work at all to calculate this.

We have a fairly busy forum, and want to streamline this.

10 Replies
Posts: 94
Topic starter
(@vanessa)
Estimable Member
Joined: 6 months ago

Hey folks, does anyone have an answer for this?

Is there support for folks who have paid for the premium upgrade?

Posts: 94
Topic starter
(@vanessa)
Estimable Member
Joined: 6 months ago

@martin thx for answering some of my earlier questions. Hope you don't mind if I mention you on this one.

2 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@vanessa,

You can use this hook code to disable it. 

add_filter( 'wpforo_topic_suggestion', '__return_false' );
(@vanessa)
Joined: 6 months ago

Estimable Member
Posts: 94
JorgeW
Posts: 105
(@jorgew)
Estimable Member
Joined: 5 years ago

Hi @vanessa,

I tried the hook on our forum and it does indeed prevent suggestions from being displayed, however the server is still "Working..." looking for them. Does this happen on your forum?

Hi @robert,

Is there a way to avoid this server load at all?

Thanks

3 Replies
(@vanessa)
Joined: 6 months ago

Estimable Member
Posts: 94

@jorgew Yah, actually I had the same results after I got a chance to try it.

It doesn't seem like it's actually stopping the server from working.

Would be great to have a way to turn off the suggested topics completely.

 

Fwiw I think this should be a toggle in the dashboard and suggestions are only really appropriate for Q&A type forums, not as much discussion forums. I'm fine with a short term workaround though.

JorgeW
(@jorgew)
Joined: 5 years ago

Estimable Member
Posts: 105

@vanessa,

Would be great to have a way to turn off the suggested topics completely.

I agree!

 

JorgeW
(@jorgew)
Joined: 5 years ago

Estimable Member
Posts: 105

@vanessa,

Maybe setting topic as "unsolved"??

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

Please update to 2.2.5 version, delete all caches and test it again.

 

1 Reply
JorgeW
(@jorgew)
Joined: 5 years ago

Estimable Member
Posts: 105

Hi @robert 

Did update to 2.2.5, deleted all caches (just once) and tried it, with no change: server kept "Working" and displaying suggestions.

Then I deleted all caches once again (even browser cache) and now it seems to have stopped.

Thanks!

 

Is this an optional setting or a fix in this new version?