Notifications
Clear all

wpForo 1.x.x [Closed] Translation issue

11 Posts
2 Users
0 Likes
911 Views
Posts: 15
 duvy
Topic starter
(@duvy)
Eminent Member
Joined: 3 years ago

Hello all,

I'm facing problems to translate in French.  POT/PO/MO files looks ok and I use it to complete some additions and/or corrections.

However, a lot is still not translated so I find an English.xml that I use to create a French.xml and start to translate some phrases. Then I add this new language in the forum. BUT some translations appears correctly and other not at all.

Using the Phrases option is very very tedious for all phrases.

My questions are :

1.what the effect of rebuilding phrases,

2. what happens when I change the xml language file.

3. How they interfere ?

Many thanks for any response and have a good day,

Duvy

PS : "échouer" in admin options are probably not correct, and I can't even find it !!

10 Replies
Sofy
Posts: 4310
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @duvy

Posted by: @duvy

1.what the effect of rebuilding phrases,

It's being used if some phrase is missing in the phrase list in the Dashboard > Forums > Phrases admin page. 

2. what happens when I change the xml language file.

3. How they interfere ?

Please read this FAQ: https://wpforo.com/community/faq/how-to-translate/

PS : "échouer" in admin options are probably not correct, and I can't even find it !!

Could you please lave a screenshot of this section? 

 

1 Reply
 duvy
(@duvy)
Joined: 3 years ago

Eminent Member
Posts: 15
 
Posted by: @sofy

2. what happens when I change the xml language file.

3. How they interfere ?

Please read this FAQ: https://wpforo.com/community/faq/how-to-translate/

PS : "échouer" in admin options are probably not correct, and I can't even find it !!

Could you please lave a screenshot of this section? 

 

Hello @soffy

I've attached a print screen with Echouer. In the meantime I found it, change it into 'Fermé' . Collapsed is more "closed" than "The ship grounded on the beach"

I allready read your recommendation about translation before I went in this forum but result was not as expected

What I did :

Check what was missing in front view. Search your doc and discover the English.xml, no French.xml

Duplicate English.xml into French.xml

Made some translations, just a few to check.

Load new French.xml in dashboard parameters/main

Check ... boom nothing

Clear ALL caches... nothing

Clean all ... nothing

Went to my explorer, clear all caches/history ... nothing

Use a fresh new explorer Firefox .... nothing

Close all explorers and close MacBook, reopen ... nothing

So I'm a bit lost and assume wpforo is rebuilding some files like wpf-themes/classic/phrases.js (date is not upgrade time, 12min later)

When this file is rebuild ? I do not see date was changed after all my tries... should be at least late yesterday.

Posts: 15
 duvy
Topic starter
(@duvy)
Eminent Member
Joined: 3 years ago

Next print screen

BTW: I use English to manage wp and French for the front end.

wpForo show me a French dashboard !! even if I'm French speaking, I'm not used to use French when it concern management and programming concepts.  Too long in English before French was applied 😎 

Posts: 15
 duvy
Topic starter
(@duvy)
Eminent Member
Joined: 3 years ago

Ok, I find a solution !!!

Rename or delete phrases.js, reload forum front page and js file is rebuild and translation appear correctly 😀 

Posts: 15
 duvy
Topic starter
(@duvy)
Eminent Member
Joined: 3 years ago

Oops ... still not working

Page 1 / 2