Notifications
Clear all

wpForo 1.x.x [Solved] unavailable to Edit or delete topic/post

6 Posts
3 Users
1 Likes
454 Views
goodbbai
Posts: 2
Topic starter
(@goodbbai)
New Member
Joined: 2 years ago

1. when i click "edit" button to edit post, it seems it has wrong class. so i replace wpf-include/class-template.php

to <... class="wpf-action wpforo-edit"> from <... class="wpforo-edit wpf-action"> 

 

2. whether i change source or not, i can't edit or delete post. i already check admin page about

"Allow Edit Own Topic/post for" and "Allow delete Own Topic/post for". it set to 0.

i also change my theme but it is still not work.

 

when i click "delete", there is some error on console in safari.

"Failed to load resource: the server responded with a status of 400 (Bad Request)

https://mysite/wp-admin/admin-ajax.ph p"

it returns 0.

 

how can i fix it?

 

[removed]

5 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @goodbbai,

Thank you for the detail.

We are going to check it. Please wait a bit, I'll update the topic asap.

Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

@goodbbai,

..... so i replace wpf-include/class-template.php

to <... class="wpf-action wpforo-edit"> from <... class="wpforo-edit wpf-action"> 

You made changes in the wpForo codes, that cause the issue. But please note you don't have permission to make such changes.

Please deactivate wpForo, then delete it. Then go to wordpress.org find, download, then activate it again.

goodbbai
Posts: 2
Topic starter
(@goodbbai)
New Member
Joined: 2 years ago

i did what you said.

and changed test forum to

[link removed]

 

it still have problems regarding edit/delete.

Only admin can delete it in Admin page>Forum>Moderation. but users can't.

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@goodbbai,

This is HTTPS protocol issue. Somewhere your website set with https:// protocol, but you still access to your website with http:// protocol. When you click any button, browser block the actions because all actions tries to reach from http:// website to https:// content.

If you have a valid SSL certificate and can enable https:// protocol:

  • Please check your website URLs in Dashboard > Settings > General admin page, make sure they are set with https:// protocol.
  • Then go to Dashboard > Plugins admin page and install WP Force SSL plugin to not allow users use your websites with http:// protocol.
  • Then go to Dashboard > Forums > Settings > General Tab and click [update options] to reset wpForo Base URL with the correct https:// protocol.

If you don't have a valid SSL certificate and cannot enable https:// protocol:

  • You should set all URLs in Dashboard > Settings > General admin page are set with http:// protocol.
  • Then go to Dashboard > Forums > Settings > General Tab and click [update options] to reset wpForo Base URL with the correct http:// protocol.
goodbbai
Posts: 2
Topic starter
(@goodbbai)
New Member
Joined: 2 years ago

it's fixed! thx!

my site is multi site installed wordpress, so i refer to following steps.

https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/