Notifications
Clear all

[Solved] User registration not working

5 Posts
2 Users
1 Reactions
628 Views
Posts: 4
Topic starter
(@txiki1)
Active Member
Joined: 1 year ago

Hi guys,

when I click the register button, the URL changes ( https://www.testleser-theke.de/?redirect_to=https%3A%2F%2Fwww.testleser-theke.de%2F), but nothing else happens, the homepage displays again,  meaning no registration form or such.

Also, when I click on a forum title, nothing happens at all -

e.g. https://www.testleser-theke.de/forum/fuer-testleser-hier-koennt-ihr-euch-vorstellen/

 

This happens, when I access the site from a different browser (not logged into WP), like any visitor would.

I have "anybody can register" enabled in General settings.

 

Please help.

 

4 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @txiki1,

How have you set wpForo on your homepage?

Posts: 4
Topic starter
(@txiki1)
Active Member
Joined: 1 year ago

Hi @chris,

 

thank you for the reply.

 

IN WP Settings > Reading I selected  Your homepage displays "a static page" and selected the main page (Hauptseite) as  hompeage.

I hope this is the info you are looking for.

 

In the wpForo Showcase Forum I saw some pages that had the forum on the home page and for my purposes that would be ideal instead of having the forum on a sub page.

 

Can this be fixed?

 

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@txiki1,

No, that's not the right way to do it, please bring it back to default, then navigate to Dashboard > wpForo > Boards, edit the Board, and enable "Turn WordPress to this forum board" option.

Posts: 4
Topic starter
(@txiki1)
Active Member
Joined: 1 year ago

thanks, at first I didn´t understand what you mean but I found it in the documentation:

 

https://wpforo.com/docs/wpforo-v2/getting-started/forum-page/set-forum-on-home-page/

now it is working

People, check out the documentation, it is quite good 😀