Notifications
Clear all

wpForo 1.x.x [Solved] wpForo and JustWrite and BuddyPress

26 Posts
4 Users
1 Likes
1,296 Views
joshfree
Posts: 28
Topic starter
(@joshfree)
Eminent Member
Joined: 3 years ago

I'm using these together on a site I just installed today. And I am a non-coder WP user. Two questions:

1. Do I actually need JustWrite? And if not, how would I delete/remove it without breaking things? I love the look but I find I am confused with pages that wpForo builds vs. those that JustWrite builds. Not sure what's safe to change and where to edit things. (This is a straight forum, not part of a larger website.)

2. My "lost password" function does not work. I saw a previous post about this here, so am wondering if JustWrite creates its own page? (I tried the suggested Custom Authorization URL and got a 404 error.) Or if something else is breaking this — perhaps somewhere in BuddyPress? I have no idea where to look or how to find out.

Thanks for any help.

25 Replies
Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 7 years ago

Not sure i understand the questions about Justwrite.

Justwrite is theme like all the others and wpForo a plugin like the others.

You can install any theme you want and use it with wpForo.

Reply
1 Reply
joshfree
(@joshfree)
Joined: 3 years ago

Eminent Member
Posts: 28

@anonymous20 Thank you. I'm glad to know I can use any theme including JustWrite (which several people have recommended to use with wpForo).

 

Reply
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago
Posted by: @joshfree

Do I actually need JustWrite? And if not, how would I delete/remove it without breaking things?

I'm sorry but I'm not familiar with JustWrite theme. We may suggest to contact the JustWrite theme support.

My "lost password" function does not work. 

Please follow Robert's answer in this support topic: https://wpforo.com/community/problem-and-bug-reports/lost-your-password-bug/

(I tried the suggested Custom Authorization URL and got a 404 error.) Or if something else is breaking this — perhaps somewhere in BuddyPress? I have no idea where to look or how to find out.

Please let us know have you fill those fields with the values from BuddyPress? 

The fields are located in the  Dashboard > Forums > Settings > Members admin page  "Custom Authorization URLs" section.

Reply
1 Reply
joshfree
(@joshfree)
Joined: 3 years ago

Eminent Member
Posts: 28

@alvina I had already seen Robert's post and tried it.

 

If I have /forgot-password/ in the Custom Authorization URL field for Lost Password:

When I click "Lost your password" from the first login screen, I am taken to a 404 page, even using a fresh browser with a refreshed cache. 

 

If the field is left blank:

I am taken to what looks like the wpForo "Forgot Your Password?" screen with a Captcha checkbox. (Yes, I have that enabled and installed for this site.)

When I click the blue RESET PASSWORD button, the site seems to process for several seconds, then I am taken to a standard WP login screen (see screenshot). No notice about getting an email. No other information.

I do get an email, though, but there is no link to reset the password. Instead it says (verbatim):

Hello!You asked us to reset your password for your account using the email address JoshTest.If this was a mistake, or you didn\'t ask for a password reset, just ignore this email and nothing will happen.To reset your password, visit the following address:Thanks!

Do you have any idea what is happening with this? I do have BuddyPress installed (at your documentation's suggestion). Please advise ASAP. I would like to launch the site tomorrow with this working. Thanks!

 

 

Reply
joshfree
Posts: 28
Topic starter
(@joshfree)
Eminent Member
Joined: 3 years ago

@alvina and @anonymous20 — I hope you can help me with this question. I can't launch my site until this is working.

You are welcome to try logging in as a member, then seeing what happens if you pretend to forget your password. It's a mess. I have gotten several complaints from friends who are testing the site for me.

www.workchat.freeassoc.com

Thanks.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9714

@joshfree,

All is confused. Why are you using different solution for login for register for reset password and for user activation?

Your Login page: http://workchat.freeassoc.com/login/

Your Registration page: http://workchat.freeassoc.com/register/

Your password reset page: http://workchat.freeassoc.com/community/?foro=lostpassword

 

Please let me know why don't you use wpForo Login/Register/Reset password page, but instead of that you use this mess?  What is the reason of BuddyPress installation?

Reply
joshfree
Posts: 28
Topic starter
(@joshfree)
Eminent Member
Joined: 3 years ago

I installed BuddyPress because (I think) your documentation recommended it. I don't really know what it does yet!

I can deactivate or uninstall BuddyPress if I don't need it.

I would be happy learn how to make this work, and keep things as simple as possible. What do you suggest?

Reply
Page 1 / 3
Share: