Go2wpForo Migration...
 
Notifications
Clear all

[Solved] Go2wpForo Migration Tool does not work

14 Posts
3 Users
3 Likes
1,782 Views
0
Topic starter

Hello. I want to migrate my asgaros forum to wpforum. But Go2wpForo Migration Tool does not work. I installed both wpforo and Go2wpForo Migration Tool then I enter dashboard>Go2wpForo Migration Tool and clicked asgarosforum. But new opened page was empty. There is nothing. So I could not migrate asgaros to wpforo. Can you say me what is problem? Does Go2wpForo Migration Tool not work anymore?

Topic Tags
8 Answers
0
Topic starter

I guess I have found the problem. Wpforo shows mysql version as 5.5.5. But wpforo itself works properly though Go2wpForo doesn't work. So, I asked support my hosting. I said that could you mysql version update 5.6 or higher. They replied me "Our servers have MariaDB 10.2, which is much higher than MySQL 5.6. The out-dated softwares may not see the version, but it is the new version."

And I said that "So is there a way to solve this problem?". They replied that "The problem can be solved by codes, there is no server-based operation to do. MySQL 5.6 codes are running in MariaDB 10.2 There is no mismatch"

Please help me. What can I do? Can Go2wpForo developer team fix this issue? Can it be fixed with new updates. If so, I can wait the new version of Go2wpForo. Thanks

 

0

We run wpForo with 10.3.28-MariaDB-log-cll-lve. I think their reply is correct.

0
Topic starter

Now I tried my other site at another server. This also shows 5.5.5 but Go2wpForo has worked. Unfortenately, my asgaros forum is not in that site, it is useless for me. But even I understand that the problem is not sourced from Mysql version.

0

I would suggest to check 2 things.

1. If there is any error in your browser console (F12) while doing all these ....

2. Enable WP debug to a LOG and check for errors.

 

 

0

@selsebil,

I think the Go2wpForo tool was uploaded and installed incorrectly.

Please deactivate the plugin, delete it, download from the Migration Section again, and upload to your website, then activate it.

Then disable all other plugins (in any case). And try it again.

If you see the same issue, go to Dashboard > Forums > Tools > Debug Tab and check the Errors & Issues Tab, if you see any error, please copy, put in a txt file and attach it here.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

selsebil selsebil Topic starter 16/05/2021 8:27 am
Posted by: @robert

@selsebil,

I think the Go2wpForo tool was uploaded and installed incorrectly.

Please deactivate the plugin, delete it, download from the Migration Section again, and upload to your website, then activate it.

Then disable all other plugins (in any case). And try it again.

If you see the same issue, go to Dashboard > Forums > Tools > Debug Tab and check the Errors & Issues Tab, if you see any error, please copy, put in a txt file and attach it here.

Thank you for help. I installed and removed the plugin many times. I disabled all third party plugin and then shifted wordpress theme, but nothing changed. Debug mode shows some errors. I copy and paste below. Thanks for your attention.

 

  • [16-May-2021 08:21:55 UTC] PHP Warning: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php71) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • [16-May-2021 08:21:55 UTC] PHP Warning: session_start(): open(/var/cpanel/php/sessions/ea-php71/sess_d1496b6e5d2564b8ccaae166b67a744f, O_RDWR) failed: No such file or directory (2) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • [16-May-2021 08:21:38 UTC] PHP Warning: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php71) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • [16-May-2021 08:21:38 UTC] PHP Warning: session_start(): open(/var/cpanel/php/sessions/ea-php71/sess_d1496b6e5d2564b8ccaae166b67a744f, O_RDWR) failed: No such file or directory (2) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • [16-May-2021 08:21:16 UTC] PHP Warning: session_start(): Failed to read session data: files (path: /var/cpanel/php/sessions/ea-php71) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • [16-May-2021 08:21:16 UTC] PHP Warning: session_start(): open(/var/cpanel/php/sessions/ea-php71/sess_d1496b6e5d2564b8ccaae166b67a744f, O_RDWR) failed: No such file or directory (2) in /home/bilimveyaratilis/public_html/wp-content/plugins/go2wpforo/migrate2wpforo.php on line 56
  • FROM `euarv_wfblocks7` WHERE `type` IN (7) AND (`expiration` = 0 OR `expiration` > UNIX_TIMESTAMP()) ORDER BY `typeSort` ASC, `id` DESC sorgusu için WordPress veritabanı hatası Commands out of sync; you can't run this command now
  • END AS `detailSort`
  • ELSE 9999
  • WHEN `type` = 8 THEN `IP`
  • WHEN `type` = 2 THEN `IP`
  • WHEN `type` = 7 THEN `IP`
  • WHEN `type` = 6 THEN `IP`
  • WHEN `type` = 5 THEN `IP`
  • WHEN `type` = 9 THEN `IP`
  • WHEN `type` = 1 THEN `IP`
  • WHEN `type` = 4 THEN `parameters`
  • WHEN `type` = 3 THEN `parameters`
  • END AS `typeSort`, CASE
  • ELSE 9999
  • WHEN `type` = 1 THEN 8
  • WHEN `type` = 2 THEN 7
  • WHEN `type` = 8 THEN 6
  • WHEN `type` = 9 THEN 5
  • WHEN `type` = 5 THEN 4
  • WHEN `type` = 6 THEN 3
  • WHEN `type` = 7 THEN 2
  • WHEN `type` = 4 THEN 1
  • WHEN `type` = 3 THEN 0
  • [15-May-2021 13:44:15 UTC] wfWAFIPBlocksController::synchronizeConfigSettings, wfBlock::lockouts, wfBlock::allBlocks tarafından oluşturulan SELECT *, CASE
  • FROM `euarv_wfblocks7` WHERE `type` IN (1, 8, 9, 2, 5, 6) AND (`expiration` = 0 OR `expiration` > UNIX_TIMESTAMP()) ORDER BY `typeSort` ASC, `id` DESC sorgusu için WordPress veritabanı hatası Commands out of sync; you can't run this command now
  • END AS `detailSort`
  • ELSE 9999
  • WHEN `type` = 8 THEN `IP`
  • WHEN `type` = 2 THEN `IP`
  • WHEN `type` = 7 THEN `IP`
  • WHEN `type` = 6 THEN `IP`
  • WHEN `type` = 5 THEN `IP`
  • WHEN `type` = 9 THEN `IP`
  • WHEN `type` = 1 THEN `IP`
  • WHEN `type` = 4 THEN `parameters`
  • WHEN `type` = 3 THEN `parameters`
  • END AS `typeSort`, CASE
  • ELSE 9999
  • WHEN `type` = 1 THEN 8
  • WHEN `type` = 2 THEN 7
  • WHEN `type` = 8 THEN 6
  • WHEN `type` = 9 THEN 5
  • WHEN `type` = 5 THEN 4
  • WHEN `type` = 6 THEN 3
  • WHEN `type` = 7 THEN 2
  • WHEN `type` = 4 THEN 1
  • WHEN `type` = 3 THEN 0
  • [15-May-2021 13:44:15 UTC] wfWAFIPBlocksController::synchronizeConfigSettings, wfBlock::ipBlocks, wfBlock::allBlocks tarafından oluşturulan SELECT *, CASE
  • FROM `euarv_wfblocks7` WHERE `type` IN (3) AND (`expiration` = 0 OR `expiration` > UNIX_TIMESTAMP()) ORDER BY `typeSort` ASC, `id` DESC sorgusu için WordPress veritabanı hatası Commands out of sync; you can't run this command now
  • END AS `detailSort`
  • ELSE 9999
  • WHEN `type` = 8 THEN `IP`
  • WHEN `type` = 2 THEN `IP`
  • WHEN `type` = 7 THEN `IP`
  • WHEN `type` = 6 THEN `IP`
  • WHEN `type` = 5 THEN `IP`
  • WHEN `type` = 9 THEN `IP`
  • WHEN `type` = 1 THEN `IP`
  • WHEN `type` = 4 THEN `parameters`
  • WHEN `type` = 3 THEN `parameters`
  • END AS `typeSort`, CASE
  • ELSE 9999
  • WHEN `type` = 1 THEN 8
  • WHEN `type` = 2 THEN 7
  • WHEN `type` = 8 THEN 6
  • WHEN `type` = 9 THEN 5
  • WHEN `type` = 5 THEN 4
  • WHEN `type` = 6 THEN 3
  • WHEN `type` = 7 THEN 2
  • WHEN `type` = 4 THEN 1
  • WHEN `type` = 3 THEN 0
  • [15-May-2021 13:44:15 UTC] wfWAFIPBlocksController::synchronizeConfigSettings, wfBlock::countryBlocks, wfBlock::allBlocks tarafından oluşturulan SELECT *, CASE
  • FROM `euarv_wfblocks7` WHERE `type` IN (4) AND (`expiration` = 0 OR `expiration` > UNIX_TIMESTAMP()) ORDER BY `typeSort` ASC, `id` DESC sorgusu için WordPress veritabanı hatası Commands out of sync; you can't run this command now
  • END AS `detailSort`
  • ELSE 9999
  • WHEN `type` = 8 THEN `IP`
  • WHEN `type` = 2 THEN `IP`
  • WHEN `type` = 7 THEN `IP`
  • WHEN `type` = 6 THEN `IP`
  • WHEN `type` = 5 THEN `IP`
  • WHEN `type` = 9 THEN `IP`
  • WHEN `type` = 1 THEN `IP`
  • WHEN `type` = 4 THEN `parameters`
  • WHEN `type` = 3 THEN `parameters`
  • END AS `typeSort`, CASE
  • ELSE 9999
  • WHEN `type` = 1 THEN 8
  • WHEN `type` = 2 THEN 7
  • WHEN `type` = 8 THEN 6
  • WHEN `type` = 9 THEN 5
  • WHEN `type` = 5 THEN 4
  • WHEN `type` = 6 THEN 3
  • WHEN `type` = 7 THEN 2
0
Topic starter

I left a review for wpforo. Snapshot is attached.

 

Robert Robert 17/05/2021 3:58 am

Hi @selsebil,

Thank you very much for the nice review.

As far as i see the PHP Session path is changed in your hosting server and there is no way to call it. PHP session is used by Go2wpForo tool, so you should fix this issue in the server.

What is set in the php.ini file for session.save_path ?
Most likely you'd find this (depending on your configuration) in cPanel >Software> MultiPHP INI Editor

In some cases the session.save_path is changed by local settings via .user.ini or .htaccess located in the root directory of your website. You can use cPanel > File Manager to check them or connect via FTP Client like FileZilla.

The files need to be checked:

/home/$user/public_html/.htaccess
/home/user/public_html/*.ini

 

Related Topics:

selsebil selsebil Topic starter 17/05/2021 7:44 pm

@robert You were right. My hosting said me that my problem is sourced from a bad code in php.ini. They cleared it, but the plugin didn't work again.

dimalifragis dimalifragis 17/05/2021 8:50 pm
Posted by: @selsebil

@robert You were right. My hosting said me that my problem is sourced from a bad code in php.ini. They cleared it, but the plugin didn't work again.

Just find a proper hosting company.

 

0
Posted by: @selsebil

@robert You were right. My hosting said me that my problem is sourced from a bad code in php.ini. They cleared it, but the plugin didn't work again.

You've not fixed the problem. Please read my post again. Your PHP searches the session folder in /var/cpanel/php/sessions/ea-php71/ directory, but it's not there, something has changed it and made lots of problems with PHP, they should let you know why the session files cannot be found in the /var/cpanel/php/sessions/ea-php71/ directory, and why PHP refers to this directory. They should fix this issue. Deleting the PHP.ini file is not a solution.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

selsebil selsebil Topic starter 20/05/2021 8:54 am

@robert Dear support team. Thank you very much. I transmitted your proposals to my hosting. Then they investigated again, and foond that the problem is related to htacces file. Thus, the plugin works now. 

I have an important question, now. Because the plugin has not worked so far, I despaired of transportation of old forum. Then I began to use wpforo in my site. So, members have started many new topics in wpforo. Now, if I transmit old asgarosforum topics using Go2wpForo, may new posts in wpforo be deleted? Or, will both old asgaros posts and new wpforo posts be present in wpforo after transportation?

0

Hi @selsebil,

In any case, you can backup the database tables. However, there should not be any problem, if you don't delete forums then all new topics will not be lost after the migration.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

selsebil selsebil Topic starter 20/05/2021 9:52 pm

@robert Great. It worked. And I migrated all old posts. Then I redirected all old URLs, even if it was laboruous 🙂