Notifications
Clear all

wpForo 1.x.x [Solved] Missing Facebook login button

9 Posts
5 Users
1 Reactions
3,511 Views
Posts: 1
Topic starter
(@dniezby)
New Member
Joined: 6 years ago

I know this is an old topic but it's a problem that seems to still exist. 

I have everything set up correctly, (it's pretty simple actually) and enabled facebook login, however, there is no facebook login button on website OR mobile. This forum even has the problem. ( see attachment ) If you go to register or login here - no facebook button.

Do we have any updates on this issue? 

8 Replies
Robert
Posts: 10534
Admin
(@robert)
Support Team
Joined: 8 years ago

This is a device and browser specific issue. The Facebook Login button exists and it works fine. Make sure you don't use private session of browsers. Also make sure the cookies are not disabled. This is also can be internet provider issue. in any case this problem doesn't have direct relation to wpForo for sure.

vinjnr007
Posts: 30
(@vinjnr007)
Eminent Member
Joined: 4 years ago

I just recently setup my login via facebook and am have the same issue be only on mobile. I tested it on 9 mobile units and 4 different web browsers. The results is as mentioned about with @dniezby.

6 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10534

@vinjnr007

Please try this small CSS code. Put it in Dashboard > Forums > Settings > Styles > Custom CSS Code Textarea. Save it delete all caches, do Ctrl+F5 on forum front-end. Then test it on other mobile devices. Because mobile browsers have a hard cache, you'll not be able to see the change immediately.

.fb_iframe_widget iframe {
position: relative!important;
} #wpforo #wpforo-wrap .fb_iframe_widget, #wpforo #wpforo-wrap .fb_iframe_widget span {
width: auto;
}

Also, please don't use Private Session of mobile browsers. Facebook doesn't allow use Login Button on private sessions, it doesn't allow use Cookies so make sure you use regular (default) mode of mobile browser.

vinjnr007
(@vinjnr007)
Joined: 4 years ago

Eminent Member
Posts: 30

@robert

Thank you. After implementing your suggestion, It's now working perfectly.

(@jthomasfitch)
Joined: 4 years ago

New Member
Posts: 2

@robert I'm having the same problem do I need to just add that line of code or do I need to delete whats already in the box and replace with what you shared?

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10534

@jthomasfitch,

Just add the code don't delete anything. The new CSS codes should be added below the old ones.

(@jthomasfitch)
Joined: 4 years ago

New Member
Posts: 2

@robert Thank you that did the trick. I just wish I could get rid of the url can't find domain error when trying to share individual post now.

st7878
(@aima-forum)
Joined: 4 years ago

Estimable Member
Posts: 111

@robert i had the same problem. I solved it thanks to https://wpforo.com/community/postid/42344/
But, why don't you embed this code in the wpforo ready plugin? Not all users of the wpForo plugin know that this button is not always displayed, and that it needs to be improved.