Notifications
Clear all

[Closed] Ultimate Member Plugin Pages Get 404'd when WPForo is Active

3 Posts
2 Users
0 Reactions
9,108 Views
Posts: 1
Topic starter
(@weblarry)
New Member
Joined: 6 years ago

Hi all. I have a fresh WP install from today trying to test UM + WPForo. The standard UM pages (login / register / account, etc. as shown here: ) work fine when WPForo is deactivated but when I activate wpforo, they give me a 404.  

I've done the following (trying to list the order I did them in as accurately as possible, but it could be wrong).

1. Resaved Permalinks (didn't help)
2. Resaved Permalinks with custom structure /%category%/%postname%/ (didn't help, but I left them like this)

3. Set the UM settings to 'Yes' 
4. Deleted all caches using WPForo dashboard page option. 
5. Set custom authorization URLs here:  https://mysite.com.com/wp-admin/admin.php?page=wpforo-settings&tab=members so that it looked like this: 

 

Now I'm a bit stuck. Not sure where to go. The 404 pages look like this: 

 

Which is weird because these pages should have the UM styles, not be wrapped in the UM plugin. 

Any ideas? Thanks!

 

2 Replies
Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

I don't see the most important information. What is the original login/register/reset-password URLs of your website provided by UM? It would be better to leave website URL.

Also, the 3rd "Replace forum profile to UM profile" option disables forum account page with forum specific settings and options for users. I don't think this is need to be enabled.

Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

Also please make sure these options are disabled in Forums > Settings > Features admin page:

  • Replace Registration Page URL to Forum Registration Page URL
  • Replace Login Page URL to Forum Login Page URL
  • Replace Reset Password Page URL to Forum Reset Password Page URL