Notifications
Clear all

when I defer JS using WP Optimize plugin I can’t edit Wpforo Forums text box

4 Posts
3 Users
0 Likes
272 Views
naomibuch
Posts: 39
Topic starter
(@naomibuch)
Eminent Member
Joined: 3 years ago

Hi there,

 

I am facing a bit dilemma, when I enable minify JavaSript with WP Optimize plugin and defer it speeds up my website, but it comes with a cost, I can’t edit my forum text area, I am using wpForo Forums.

It goes into a spin see the link input text forum area is blocked area

How can I exclude this in javascript? I don’t want to deactivate this wonderful plugin.

I see you have exclusions for other cache plugins but I don't see anything for WP Optimize plugin. 

 

Thanks a bunch

3 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

@naomibuch,

Please read this FAQ: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Reply
pinda
Posts: 8
(@pinda)
Active Member
Joined: 2 years ago

You will be happy by excluding the following JavaScript

wp-tinymce.js,tinymce.min.js,tiny_mce_popup.js,editor.min.js

However, I'm not sure if this is correct
There may be other problems

Reply
pinda
Posts: 8
(@pinda)
Active Member
Joined: 2 years ago

I forgot, but you might want to exclude editor.js and jquery.js as well
I'm using WP Rocket and excluding the following paths that contain them

wp-includes/js/dist/
wp-includes/js/tinymce/
js/jquery/jquery.js
js/jquery/jquery.min.js

But I don't know when the problem will occur
For that, I think it is better not to use the cache plugin in the first place, or to exclude the wpForo forum page in the cache plugin settings.
If your forum is fatally slow, consider carefully excluding the above JavaScript

Reply
Share: