Clear all

[Solved] Critical error on password reset

4 Posts
2 Users
0 Reactions
Posts: 3
Topic starter
Active Member
Joined: 2 years ago

I have a Woocommerce website. Users log in through a Woocommerce login form widget.

In WPForo's settings, all WPForo forms are disabled, including the password reset form.

When WPForo is active, if I try to reset my password by submitting the WC password reset form on the WC account page, I get a WordPress critical error.

After reading about this similar issue, I tried setting the custom authorization URL for password reset to the WC password reset page, but nothing has changed even after clearing the cache.

I also tried downgrading PHP to 8.0, but that didn't help either.

You can't see the issue now because I had to disable WPForo and set a redirect from the forum page.

I could keep WPForo active and replace the WC login form with the standard WP login form, but the "lost password?" link takes to the WP admin with the big WP logo and that's not the user experience I want.

Here's the automatic error notification email I received:

WordPress version 6.1
Active theme: Hello Elementor Child (version 1.0.1)
Current plugin: wpForo (version 2.1.0)
PHP version 8.1.9

Error Details
An error of type E_ERROR was caused in line 231 of the file /home/ H"> Error message: Uncaught Error: Call to a member function reset() on null in /home/ -">
Stack trace:
#0 /home/ V"> wpforo\classes\Cache->clean()
#1 /home/ X"> wpforo_clean_cache()
#2 /home/ M"> wpforo\classes\Members->reset()
#3 /home/ b"> wpforo\classes\Members->wpforo\classes\{closure}()
#4 /home/ o"> WP_Hook->apply_filters()
#5 /home/ p"> WP_Hook->do_action()
#6 /home/ q"> do_action()
#7 /home/ q"> clean_user_cache()
#8 /home/ -"> wp_set_password()
#9 /home/ v"> reset_password()
#10 /home/ L"> require_once('/home/ E">')
#11 /home/ F"> perfmatters_wp_loaded()
#12 /home/ o"> WP_Hook->apply_filters()
#13 /home/ p"> WP_Hook->do_action()
#14 /home/ G"> do_action()
#15 /home/ t"> require_once('/home/ E">')
#16 /home/ P"> require_once('/home/ E">')
#17 /home/ 3"> require_once('/home/ E">')
#18 /home/ p"> require('/home/')
#19 {main}


3 Replies
Posts: 3
Topic starter
Active Member
Joined: 2 years ago

Since I saw the "cache.php" file in the error report, I also tried disabling my cache plugin (FlyingPress), but that didn't help either. In any case, the relevant URLs were already excluded from cache.

Posts: 10520
Support Team
Joined: 8 years ago

Hi @stefanolodola,

You just need to update to the latest wpForo 2.1.1 version. I think you still use the 2.1.0 version.

Posts: 3
Topic starter
Active Member
Joined: 2 years ago

Yes, it works now...