Notifications
Clear all

[Closed] Error when generating the sitemap

8 Posts
3 Users
2 Reactions
686 Views
Posts: 8
Topic starter
(@ailaine)
Active Member
Joined: 1 year ago

Hi,

When generating the sitemap for one of my board, I am getting the following error:

How can I solve it to get the sitemap?

Thanks

Topic Tags
7 Replies
Tutrix
Posts: 1301
(@tutrix)
Noble Member
Joined: 4 years ago

Hi @ailaine

There are probably empty lines in one of these files

In wp-config.php (WordPress) there must be no blank lines before the <?php or after the ?>.
Also in the Functions.php of the WordPress theme, there must be no blank lines before the <?php or after the ?>.

This causes 2 blank lines to appear before the <!DOCTYPE html>, resulting in an error message
Have a look at the source code of your page

dimalifragis
Posts: 2614
(@dimalifragis)
Famed Member
Joined: 4 years ago

You use Yoast anyways, why you have a second xml creation plugin from Bestwesoft?

https://xxxxxxx.com/sitemap.xml

Could be a conflict.

dimalifragis
Posts: 2614
(@dimalifragis)
Famed Member
Joined: 4 years ago

Also where is the forum?

https://xxxxxxxx.com/affiliates-faqs/sitemap.xml goes to

https://xxxxxxxx.com/wp-sitemap.xml

and not where your capture shows. All those are NOT from wpForo.

WpForo sitemap is:

(for example)

https://wpforo.com/community/sitemap.xml

 

Tutrix
Posts: 1301
(@tutrix)
Noble Member
Joined: 4 years ago

Posted by: @dimalifragis

Also where is the forum?

 https://xxxxxxxx.com/wellnesspedia-en/ 

😉

2 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@tutrix yeap, i love when users ask for help and provide no urls and data 🙂

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1301

@dimalifragis Yes, if we know the URL to the problem, we can help much better.
But it was visible in the image 😀

Page 1 / 2