Notifications
Clear all

wpForo 1.x.x I only can acess the top level forums

2 Posts
2 Users
0 Likes
1,257 Views
ariuszet
Posts: 1
Topic starter
(@ariuszet)
New Member
Joined: 6 years ago

So i installed and kind of configured the forum, got a page with the correct slug, and i can see the forum home page.

But when i start a new topic, it doesn't show.

Do i have to create a custom page for every single topic what the uers might add? Or do i miss something profanely easy?

 

1 Reply
Robert
Posts: 9267
Admin
(@robert)
Support Team
Joined: 6 years ago

wpForo creats Forum page on installation with /community/ slug. And you don't need to create custom page for each topic. I think you've done something wrong.

If you create custom forum page you should know these:

1. The initial /community/ page should be deleted permanently, not just put in "trashed".

2. New page slug should be unique, and it should be put in Dashboard > Forums > Settings > "Forum Base URL" admin page.

3. The new page should contain [wpforo] shortcode.

 

Also please make sure you use WordPress permalinks. wpForo doesn't work with default ?p=1 URL structure. Check it in Dashboard > Settings > Permalinks admin page.

 

Reply
Share: