Notifications
Clear all

wpForo 1.x.x Issue with Login and Register Links

10 Posts
3 Users
1 Likes
7,016 Views
denellum
Posts: 9
Topic starter
(@denellum)
Active Member
Joined: 6 years ago

Hello, first off, AWESOME plugin!

my url is : https://www.itdb.ws

Under the forum section I can not for the life of me get the login/registration links working.

I am on the NEWEST version of Wordpress. I also have all of my other plugins disabled.

9 Replies
denellum
Posts: 9
Topic starter
(@denellum)
Active Member
Joined: 6 years ago

I am running nginx... I don't think that should matter though.

 

Hummmm also can not change any of my information in the "account tab"

Reply
Robert
Posts: 9349
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi denellum,

I can't say what's the problem. Your server doesn't understand wpForo GET variables in URL. I'd recommend to use some Profile Plugin, like BuddyPress or Ultimate Member. these plugins come with own Login/register pages.

After installation and configuration some Profile plugin you'll got new login/register pages. Just navigate to Dashboard > Forums > Settings > Members admin page and put new page slugs to "Custom Authorization URLs" fields.

If you don't want to install Profile plugin you can put default WordPress login/register URLs in the same option fields.

  • /wp-login.php (login)
  • /wp-login.php?action=register (register)

Make sure you've enabled user registration in Dashboard > Settings > General admin page.

Reply
denellum
Posts: 9
Topic starter
(@denellum)
Active Member
Joined: 6 years ago

I'm running centminmod... ugh I was really looking forward to using this. Anything I can do to help trouble shoot for you?

Reply
denellum
Posts: 9
Topic starter
(@denellum)
Active Member
Joined: 6 years ago

Actually I got it. This is an nginx thing. Added this to my .conf file.

 

  location / {

  ##WORDPRESS STUFF##

  #try_files $uri $uri/ /index.php?q=$request_uri;

  try_files $uri $uri/ /index.php?$args;

 

  ##END WORDPRESS STUFF##

Reply
Page 1 / 2
Share: