Notifications
Clear all

[Closed] Members not showing inside 'Members' directory

5 Posts
4 Users
1 Reactions
659 Views
Posts: 2
Topic starter
(@laurabaurealis)
New Member
Joined: 1 year ago

I'm unable to view any members inside the 'members' tab, for ANY usergroup. Very frustrating. It just says "Members not found" when I navigate to the 'members' directory. 

The rest of the forums, posts and profile pages are normal.

We have over 23,000 members in our forum, but none of them are visible inside the 'members' area, either in the main directory or via search / filter.

Here's what I've done so far in my troubleshooting attempts:
  1. Updated all themes and plugins, including wpForo
  2. I logged in as both an admin and as a registered subscriber (default), but neither can see the members list. When I inspect the code, it seems that the list function is returning an error. The wpforo-members div has a class "wpf-p-error" which suggests there is something in the core code that is not loading correctly. No other database issues or console issues logged. 
  3. I changed the permalink for the members list page, thinking that perhaps there was an issue with the URL, but that didn't do anything either
  4. In the wpForo > Overview > General maintenance and Forum maintenance, I cleared all caches, updated users statistics, and re-synced users profiles. I was certain this would do SOMETHING but alas, no dice.
  5. I checked the Tools > Errors & Issues and didn't find anything there either.
  6. I triple checked all URL slugs and there are 0 conflicts with /members/

Has anyone else had this issue?
Is there someone from the wpForo support team that might be able to log in and see why we can't view members in our directory?

This is limiting our ability to connect people in our program.

4 Replies
VereK
Posts: 522
(@verek)
Honorable Member
Joined: 6 years ago

Members changed to /participants/ in V2.

1 Reply
(@laurabaurealis)
Joined: 1 year ago

New Member
Posts: 2

@verek This shouldn't matter though, since I have the Members Directory set to /members/ in the wpForo settings... right?

Wouldn't /participants/ would just be the default option for new v2 installations?

Posts: 6
(@natachagj)
Active Member
Joined: 1 year ago

I have the same issue. Were you able to solve this issue?

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @laurabaurealis, @natachagj,

Please navigate to wpForo > Usergroups, edit one of the Usergroups, and make sure that "Display on Members List" option and "Front - Can view members" Can are enabled.