Notifications
Clear all

wpForo 1.x.x [Solved] Missing Pagination for guests in extended layout still not solved

13 Posts
5 Users
8 Likes
844 Views
jeanne
Posts: 76
Topic starter
(@jeanne)
Trusted Member
Joined: 6 years ago

Hi, I've tried some of the solutions that Robert, Sophy and Anton so graciously posted for this problem. I thank all of you for all your help.  But I still have the problem. I am using MySQL 5.6. and cannot upgrade to 5.7 because my host (GoDaddy) uses the earlier version and I'm on shared Wordpress hosting.  I use extended layout. I tried the indices solution that Anton kindly posted but it didn't fix the problem. I would be grateful for any other possible solutions. 

12 Replies
CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago
Posted by: @jeanne

Hi, I've tried some of the solutions that Robert, Sophy and Anton so graciously posted for this problem. I thank all of you for all your help.  But I still have the problem. I am using MySQL 5.6. and cannot upgrade to 5.7 because my host (GoDaddy) uses the earlier version and I'm on shared Wordpress hosting.  I use extended layout. I tried the indices solution that Anton kindly posted but it didn't fix the problem. I would be grateful for any other possible solutions. 

Hello  @jeanne

You can try the steps on this post How To Debug and Check for Errors & Issues in your Forum: 

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-debug-and-check-for-errors-and-issues-in-your-forum-on-your-server/#post-28788  

If the above doesn't work, you can try this too: 

Go to Forum Dashboard > Settings > Select the "Styles" tab > and in the Custom CSS Code box, add the code below:

div.wpf-navi.wpf-navi-post-top, div.wpf-navi.wpf-navi-post-bottom {
display: block !important;
}

I tested the above code first in my forum before I posted it here. It forces the pagination to appear, if for some reason there is something that is conflicting that causes the pagination to not appear.

Try the code if it works, and if it doesn't work, just remove it again from your Custom CSS Code. Maybe the Support Team has other suggestions. 

Each of our installations are different because we all have different hosting servers, WP themes, and different WP plugins that all come into play that sometimes cause issues.  

Good luck and God bless you!

1 Reply
jeanne
(@jeanne)
Joined: 6 years ago

Trusted Member
Posts: 76

@crisw and @robert and @anton

Thank you for your help. The problem is, yes, solved. 🙂

 

Robert
Posts: 9715
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @jeanne,

Also please navigate to Dashboard > Forums > Settings > Forum Accesses Tab, find the "Read Only" access, edit it and make sure the "Can view replies" permission is enabled. Then save it, delete all caches, then delete wpForo cache in Dashboard > Forum > Dashboard admin page and test it as guest on different browser with the private mode to avoid caching.

jeanne
Posts: 76
Topic starter
(@jeanne)
Trusted Member
Joined: 6 years ago

Thank you both for such quick responses.  Will try all of this today and let you know! 

jeanne
Posts: 76
Topic starter
(@jeanne)
Trusted Member
Joined: 6 years ago

Thank you for your help.  I did everything mentioned, and problem is still there, but now the forum's time is in international format.  Wordpress is still in USA format, but need help figuring out how to get wpforo's time format to switch back to USA format.  I think it happened when I clicked all of the forum maintenance buttons, including rebuild threads and phrases, update statistics.  I have deleted the caches many times before without problems but this time I also clicked all of those forum maintenance buttons. 

I also inputed the codes that Cris suggested into Styles and it had the effect of breaking the threads completely for guest users. I use Avada child theme and perhaps it did not work because of that. You could see the main layout of the forums and topics, but when you clicked on a topic, the old structure of extended layout had disappeared and the page was clearly broken.  

So I removed this new code and saved the change and at first the problem remained.

So that's when I clicked all the buttons in the forum maintenance section of the forum dashboard. The threads now look okay again for guest users but now the time is in international format. 

Is there a way to fix the time format? 

P.S. I also checked the wp for error logs and it said there were no errors detected currently .

2 Replies
jeanne
(@jeanne)
Joined: 6 years ago

Trusted Member
Posts: 76
VereK
(@verek)
Joined: 5 years ago

Honorable Member
Posts: 388
Page 1 / 2
Share: