Notifications
Clear all

wpForo 1.x.x [Closed] Page not found for non-forum page.

5 Posts
2 Users
0 Reactions
1,834 Views
Posts: 6
Topic starter
(@khuang)
Active Member
Joined: 6 years ago

I had a page that works when wpforo is deactivated. But shows: "No forums were found here." when wpforo is activated again: 

https://ptexplain.com/terms-and-conditions/

It does the same to whatever page I create now. 

4 Replies
Robert
Posts: 10518
Admin
(@robert)
Support Team
Joined: 8 years ago

What is the reason that you've enabled the "Turn WordPress to wpForo" option? Have you read the message below this option before enabling this?

This option turns off WordPress on website front, nothing is accessible, only forum pages can be reached. You should copy non-forum page URLs and paste to the textarea below the option:

If you just want to put forum on home it's better to disable this option and use the instruction in doc:

https://wpforo.com/docs/root/getting-started/forum-page/set-forum-on-home-page/

 

1 Reply
(@khuang)
Joined: 6 years ago

Active Member
Posts: 6

Great that works! 

But now I followed the set-forum-on-home-page option, the wpforo pages are not linking successfully (ex. the recent post or the my profile page). Could you please help me with that? Thank you!

Robert
Posts: 10518
Admin
(@robert)
Support Team
Joined: 8 years ago

As it's explaned in doc, you should have two pages with [wpforo] shortcode.For the home page you should use the new created page. For example Home Forum. This page should be set as home page in WordPress > Settings > Reading admin page.

Make sure the main forum page with /community/ URL (slug) is not deleted. At the moment all forum link don't work on your website. Please follow the instruction above and make sure you set it correctly on home.

Posts: 6
Topic starter
(@khuang)
Active Member
Joined: 6 years ago

Got it thank you Robert you are the best.