Notifications
Clear all

wpForo 1.x.x [Closed] Recent posts widget is ignoring the access I set.

18 Posts
3 Users
0 Reactions
1,395 Views
tayo
Posts: 42
 tayo
Topic starter
(@tayo)
Trusted Member
Joined: 4 years ago

Hi,
I'm trying to ask a question because I can't find the right topic for me

Q1) Forum A.
I am going to make Forum A where I can see the topic but not the answer.
So, I made Forum Access AA and checked only the following two things.
1. Can view form
2. Can view topic

After setting it up, when I click on the topic, I can see the contents of the topic, but I can't see the answers related to it.
It worked as I set it up.

Q2) Forum B
I am going to make Forum B where the only forum can be seen.
So, I made Forum Access BB and checked only one of the following.
1.Can view form

After setting it up, I clicked on the topic in the forum list but confirmed that I could not see the contents of the topic normally. It worked as I set it up.


However, the problem was in the recent posts widget.
The widget showed all the answers to users who were not authorized to the forum.
1. Access AA could see the contents of the answers in the widget. (approximately 55 characters)
2. Access BB could see the contents of the topic in the widget. (approximately 55 characters)

This widget was ignoring the access I set.

I think this is a problem, and I'm looking for a way to solve it.
If there is anything I am making a mistake, please let me know.


In addition, if this is not something that can be modified immediately,
I would like to know how to temporarily change the number of characters in the content of the current posts widget to the number of characters I want, not 55 characters.

(edit)
I just found this post about the number of letters.
Is there a way to override this on my theme?
https://wpforo.com/community/how-to-and-troubleshooting-2/recent-replies-length/#post-30729

Can you tell me how?

Thank you.

17 Replies
Alvina
Posts: 1867
Moderator
(@alvina)
Member
Joined: 5 years ago

Hi @tayo,

The widget showed all the answers to users who were not authorized to the forum.

I've just asked our developers about the issue and currently, I'm waiting for the response from them. I'll update the topic asap.

Is there a way to override this on my theme?
https://wpforo.com/community/how-to-and-troubleshooting-2/recent-replies-length/#post-30729

Can you tell me how?

You just follow the Sofy instruction in the topic you mention.

Also please note only the line was changed, now it is: 782, 827.

In those lines change the 55 number to number you want.

tayo
Posts: 42
 tayo
Topic starter
(@tayo)
Trusted Member
Joined: 4 years ago

Hi @alvina,

Posted by: @alvina

I've just asked our developers about the issue and currently, I'm waiting for the response from them. I'll update the topic asap.

Thank you for thinking about my problem. I will wait.

 

Posted by: @alvina

You just follow the Sofy instruction in the topic you mention.

Also please note only the line was changed, now it is: 782, 827.

I will follow the guidelines.
Can this change be used permanently, regardless of the plugin being updated? Or should I set it up every time the plugin updates?

If I have to set it up every time, is there any way to copy the file on my theme as below?
wp-content/themes/mychildtheme/wpf-include/functions-template.php

Thank you.

1 Reply
Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@tayo,

Can this change be used permanently, regardless of the plugin being updated? Or should I set it up every time the plugin updates?

Yes, the changes will be lost, once you update the plugin. So please keep it somewhere.

tayo
Posts: 42
 tayo
Topic starter
(@tayo)
Trusted Member
Joined: 4 years ago
Posted by: @alvina

The widget showed all the answers to users who were not authorized to the forum.

I've just asked our developers about the issue and currently, I'm waiting for the response from them. I'll update the topic asap.

Hi @alvina,

I checked that this problem still exists.
Do you have any updated information about this topic?

Thank you.

3 Replies
Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@tayo,
The developers currently working on it. This will be fixed in the next version updates.

tayo
 tayo
(@tayo)
Joined: 4 years ago

Trusted Member
Posts: 42

@alvina,

Thank you for your reply.
I will wait for the update.

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@tayo,

We need to know the cache solution you use and have you excluded the forum page from your cache solution? So please answer Robert's questions in the post below: 

Robert
Posts: 10522
Admin
(@robert)
Support Team
Joined: 8 years ago

@tayo,

This is probably cache issue. Please let me know what cache solution you use?

Have you excluded the forum page from your cache solution?

More info: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

 

3 Replies
tayo
 tayo
(@tayo)
Joined: 4 years ago

Trusted Member
Posts: 42

@robert

Thank you for your reply.
I don't use cache plugin.
So, I don't think that's the cause.
And, just a moment ago, Alvina told me that the developers were preparing for an update.

The developers currently working on it. This will be fixed in the next version updates.

I think this means it's not a cache issue.

Thank you.

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@tayo,

The developers double-check and don't find such an issue. 

Please send the admin login details to info[at]gvectors.com email address. The developers check it for you.

Also please leave the mail subject here to allow us to easily find it.

tayo
 tayo
(@tayo)
Joined: 4 years ago

Trusted Member
Posts: 42

Hi @alvina,

I just sent an email.
Subject : [tayo] Recent posts widget is ignoring the access I set.

I attached an image('access issue image.pdf') to let you know my problem accurately. 

You have to see it. Then you will be able to understand the problem faster. 

Thank you.

Page 1 / 2