Notifications
Clear all

wpForo 1.x.x [Solved] Registration error: couldn't register you... please contact the site admin!

5 Posts
2 Users
1 Likes
852 Views
Sujal
Posts: 8
Topic starter
(@sujal)
Active Member
Joined: 1 year ago

Hi there,

I have this site and I just installed wpforo so it is a fresh installation. Though, I used buddyboss for forums only before this plugin and I think now that is deactivated, it couldn't have sent the issue.

I tried to register as a new user in a guest window without any console errors or wp debugging errors. But, the error as stated: couldn't register you... please contact the site admin! appears at the top right corner.

I enabled user accounts may be registered from my multisite network and enabled wpforo registration with email link. I use wordfence for security and once I enabled login and registration captcha on wordfence and it did pose a problem but since then I disabled captcha and it just gets me this error.

I don't use any caching plugin, the only plugins I have activated for now are: astra pro, footnotes by mark cheret, health check and troubleshooting,  query monitor, really simple ssl, Stop Generating Unnecessary Thumbnails, updraftplus, wordfence, wp debugging by andy fragen and wp file manager along with wpforo. Previously I had also activated http headers plugin by Dimitar Avanov but I deactivated it.

I use the popular astra theme by brainstorm force along with astra pro.

Please note that this is a multisite installation.

Let me know if you need some additional information to help me troubleshoot this problem.

4 Replies
Sujal
Posts: 8
Topic starter
(@sujal)
Active Member
Joined: 1 year ago

Okay. I get some jquery warnings in the console if that might be the problem.

Sujal
Posts: 8
Topic starter
(@sujal)
Active Member
Joined: 1 year ago
[27-Aug-2021 06:12:52 UTC] WordPress database error Unknown column 'spam' in 'field list' for query INSERT INTO `QdcpzrKAusers` (`user_pass`, `user_nicename`, `user_email`, `user_url`, `user_registered`, `user_activation_key`, `display_name`, `user_login`, `spam`) VALUES ('$P$BT93a9y7aztndBC/JcJjcNaB5rYq8S/', 'drno', 'email@gmail.com', '', '2021-08-27 06:12:52', '', 'drno', 'drno', 0) made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, QM_DB->query

[27-Aug-2021 06:12:52 UTC] WordPress database error Unknown column 'spam' in 'where clause' for query SELECT COUNT(ID) as c FROM QdcpzrKAusers WHERE spam = '0' AND deleted = '0' made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, do_action('user_register'), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts, QM_DB->query

[27-Aug-2021 06:16:59 UTC] WordPress database error Unknown column 'spam' in 'field list' for query INSERT INTO `QdcpzrKAusers` (`user_pass`, `user_nicename`, `user_email`, `user_url`, `user_registered`, `user_activation_key`, `display_name`, `user_login`, `spam`) VALUES ('$P$BIdrRsE.vl0jc8Wl52e8CikKBhLt3K1', 'drno', 'email@gmail.com', '', '2021-08-27 06:16:59', '', 'drno', 'drno', 0) made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, QM_DB->query

[27-Aug-2021 06:16:59 UTC] WordPress database error Unknown column 'spam' in 'where clause' for query SELECT COUNT(ID) as c FROM QdcpzrKAusers WHERE spam = '0' AND deleted = '0' made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, do_action('user_register'), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts, QM_DB->query

[27-Aug-2021 06:18:00 UTC] WordPress database error Unknown column 'spam' in 'field list' for query INSERT INTO `QdcpzrKAusers` (`user_pass`, `user_nicename`, `user_email`, `user_url`, `user_registered`, `user_activation_key`, `display_name`, `user_login`, `spam`) VALUES ('$P$BmEWuMnQ3QtFJLK1v4nAm4d4AphZBf.', 'drno', 'email@gmail.com', '', '2021-08-27 06:18:00', '', 'drno', 'drno', 0) made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, QM_DB->query

[27-Aug-2021 06:18:00 UTC] WordPress database error Unknown column 'spam' in 'where clause' for query SELECT COUNT(ID) as c FROM QdcpzrKAusers WHERE spam = '0' AND deleted = '0' made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, do_action('user_register'), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts, QM_DB->query

[27-Aug-2021 06:34:24 UTC] WordPress database error Unknown column 'spam' in 'field list' for query INSERT INTO `QdcpzrKAusers` (`user_pass`, `user_nicename`, `user_email`, `user_url`, `user_registered`, `user_activation_key`, `display_name`, `user_login`, `spam`) VALUES ('$P$B1Ooketeq1VeoPfA096aSFlxpDrDCV1', 'drno', 'email@gmail.com', '', '2021-08-27 06:34:24', '', 'drno', 'drno', 0) made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, QM_DB->query

[27-Aug-2021 06:34:24 UTC] WordPress database error Unknown column 'spam' in 'where clause' for query SELECT COUNT(ID) as c FROM QdcpzrKAusers WHERE spam = '0' AND deleted = '0' made by require('wp-blog-header.php'), wp, WP->main, do_action_ref_array('wp'), WP_Hook->do_action, WP_Hook->apply_filters, wpForo->init, do_action('wpforo_after_init'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->do_actions, do_action('wpforo_action_wpforo_registration'), WP_Hook->do_action, WP_Hook->apply_filters, wpForoAction->registration, wpForoMember->create, register_new_user, wp_create_user, wp_insert_user, do_action('user_register'), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts, QM_DB->query

After further investigation, I got the debug log and if I can show you, it read as: And I really think all the errors I am having for my users are due to this spam column though as I can see in the database, there is a column name spam in the users table and as there is only 1 user i.e., me it shows the value of spam as 0. This is multisite and I somewhere read there is always this spam column in a multisite. Please help me finish this problem with my forum.

 
1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1962

Hi @sujal,

wpForo doesn't have such a phrase response, that may come from another plugin.

Sujal
Posts: 8
Topic starter
(@sujal)
Active Member
Joined: 1 year ago

Hey, could you please just remove my website url from the topic? I think I am getting some fake users from here. Anyways, just help me getting my site url off this page and remove this reply too.

And yeah, the issue's now solved. I just created a fresh installation of wordpress multisite and copied the site by hand from scratch as the database was actually too corrupted to import to another fresh installation which I checked through localhost.

Share: