Notifications
Clear all

wpForo 1.x.x [Solved] Remove member profile button icons beneath avatar

14 Posts
2 Users
0 Likes
1,660 Views
hill-seeker91
Posts: 17
Topic starter
(@hill-seeker91)
Active Member
Joined: 3 years ago

Hi Am setting up a private forum integrated with UM membership plugin.

To keep the design as simple and lean as possible I've removed the profiles tab on the UM profile - links to the profile just show their UM profile and no additional forum info.

How do I remove the member profile buttons underneath their avatar in the forums? (wpf-member-profile-buttons class). Happy that their image links directly to their profile, but the rest of the icons below it no longer link to anything accessible?

Apols if this isn't a bug, but it seems a bug to me to allow me to remove the profile tab (which removes activity and subscriptions info) but still try and show them with these icons...

13 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

All those icons (Profile, Activity, Subscriptions) have the same cloass wpf-member-profile-button. If you'd like to hide only the profile icon, you should use the CSS :nth-child() selector. So you should use the following CSS code:

a.wpf-member-profile-button:first-child {
display: none !important;
}

The CSS code should be added in the "Custom CSS code" textarea, located in the Dashboard > Forums > Settings > Style Tab.  

Please don't forget to delete all caches and press Ctrl+F5 (twice) on the frontend before checking to reload the updated CSS file.    

Reply
2 Replies
hill-seeker91
(@hill-seeker91)
Joined: 3 years ago

Active Member
Posts: 17

@sofy Thank you so much - that's really helpful.

(Ironically, the profile icon was the only one I wasn't concerned about staying, it was the others I needed to disappear as I don't use the forum tab on the UM profile, and the profile can be accessed by clicking on the members photo).

But your code gives me the ability to work out how to do that (drop the first child from the statement so it's

a.wpf-member-profile-button {
display: none !important;
}

And the buttons magically disappear 🙂

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@hill-seeker91,

Please let us know, do you have any questions regarding this? Can we mark this topic as solved? 

 

Reply
hill-seeker91
Posts: 17
Topic starter
(@hill-seeker91)
Active Member
Joined: 3 years ago

Yep, seems solved - many thanks 🙂

Reply
hill-seeker91
Posts: 17
Topic starter
(@hill-seeker91)
Active Member
Joined: 3 years ago

Just realised I spoke too soon. This is a great workaround but the underlying bug (that the buttons appear when a user has disabled showing tabs) still remains.

It's a bug as the buttons don't lead to where they say they will - they go to the member profile view, but not activity or subscriptions as that's not available.

Probably wants to be fixed as a minor update in a future release? But this certainly works as a workaround for me.

Thanks

Reply
1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@hill-seeker91,

Don't follow you well. Please explain using some screenshots. 

 

Reply
hill-seeker91
Posts: 17
Topic starter
(@hill-seeker91)
Active Member
Joined: 3 years ago

OK here goes...

If the "Ultimate Member Profile Forum Tab Integration" is enabled in Dashboard > Forums > Settings > Features then all works ok.

(several posts coming - can only attach 1 image at a time?)

Reply
Page 1 / 3
Share: