Notifications
Clear all

SLL certificate required

20 Posts
3 Users
0 Likes
532 Views
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 4 months ago

The last time I ran a test of a user trying to reply to a topic the same error transpired. In a generic sense the page to be accessed is www.website.com/community/forum/topic. All the topic files exist in the database. You told me that not having a SSL certificate was the reason. The "page not found" contains a folder /community/. My thought was that it should have been installed in the site's directory because the reference seems local. WpForo was loaded as a WPress plugin so all required files should be present.
Just checked the progress of adding a free SSL cert at my host. I said, "This is the first time I've seen any ref about info needed on domain redirection (I'm not even sure what that means). The forum uses SSL for processing with their software instead of http// for security purposes. But somehow there are modifications to install the SSL [by the host] which I know nothing about which are either simple adjustments or major changes. If its such a complicated endeavor then I'll tell them that too much is required regarding how much is involved to make the change."

19 Replies
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 4 months ago

Topic should have been SSL instead.

Reply
adisaputro
Posts: 127
(@adisaputro)
Estimable Member
Joined: 5 years ago

If you're using shared hosting, you can install free Let's Encrypt SSL for your domain, or if you're using Cloudflare, you can also get free SSL by simply enabling the proxy there.

Reply
Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

@norcom41,

wpForo doesn't require SSL certificate, but current web rules require it. If you don't have SSL certificate your site will never be promoted. So first you should install WordPress and make sure your website has a valid SSL certificate with https protocol, then install plugins like wpForo. 

wpForo itself doesn't require SSL certificate, so the certificate is needed for your website not for wpForo. It is used for login/logout by WordPress not by wpForo.

Reply
Posts: 25
Topic starter
(@norcom41)
Eminent Member
Joined: 4 months ago

I just got a notification that my web host has installed my SSL certificate.  So I tried to execute a reply from my test user to a topic in the forum I set up.  Got the "page not found" error again.  The first response is "Welcome back" because the login was successful.  It's trying to display a page so a reply can be made.  In the URL for that page the forum slug is provided as well as the slug for the topic chosen and this data exists in my database.  In the URL is the community folder which is missing because I checked the File Manager and that folder is not on my site.  But I'm looking at the URL on the screen from you and it says "wpforo.com/community/etc.  There is a "community" folder on your end but the reply request looking for the same on my end can't find it.  To me that shows that something was not loaded on my site when the plugin was installed.

Reply
Page 1 / 4