Notifications
Clear all

wpForo 1.x.x slow queries

26 Posts
4 Users
2 Likes
974 Views
Mondesensuel
Posts: 51
Topic starter
(@mondesensuel)
Trusted Member
Joined: 6 years ago

Hello,

I have many slow queries on my forum. How I can to fix it ?

Thank you

 

25 Replies
Martin
Posts: 883
Moderator
(@martin)
Support Team
Joined: 7 years ago

Hi @mondesensuel,

1. Please let me know what Table Engine (InnoDB or MyISAM) is used for tables with _wpforo_ secondary prefixes in the database? You can use phpMyAdmin plugin to check it.

 

2. Make sure these options are enabled in Dashboard > Forums > Settings > Features Tab:

  • Enable Member Cache
  • Enable Object Cache
  • Enable Options Cache
  • Enable Memory Cache

 

3. Check the issues in the Dashboard > Forums > Tools > Debug Tab > Tables Sub-tab. If you see any issue, please click the [Solve Database Problems] button. 

Reply
Mondesensuel
Posts: 51
Topic starter
(@mondesensuel)
Trusted Member
Joined: 6 years ago

Hi,

thank you for your fast answer.

1.It's InnoDB.

2. all is enable (member cache was not)

3. no probems found in database

Less slower queries, but more time 🙁

 

 
Reply
5 Replies
Martin
Moderator
(@martin)
Joined: 7 years ago

Support Team
Posts: 883

@mondesensuel,

Could you please leave a similar screenshot of your _wpforo_ tables?

Reply
Martin
Moderator
(@martin)
Joined: 7 years ago

Support Team
Posts: 883

Also, try to change the wp_wpforo_visits table engine to MyISAM using the corresponding option in the "Operations" Tab of the phpMyAdmin tool.

Reply
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

done, but now :

 

Reply
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51
dimalifragis
Posts: 1915
(@dimalifragis)
Noble Member
Joined: 3 years ago

Could you try to disable Wordpfence for a few minutes and check again if something changes.

Reply
5 Replies
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

@dimalifragis yes it's better but my website isn't protected 🙁

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1915
Posted by: @mondesensuel

@dimalifragis yes it's better but my website isn't protected 🙁

Nothing will happen to your site for 5 minutes.

 

Reply
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1915

@mondesensuel What kind of hosting plan are you using? PHP ? DB ? memory ?

Is a big site? Big wpForo ?

Reply
Martin
Posts: 883
Moderator
(@martin)
Support Team
Joined: 7 years ago

I don't see big issues related to wpForo anymore. You can change the table Engine for these two tables as well:

  • wp_wpforo_profiles
  • wp_wpforo_likes
Reply
2 Replies
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

@martin I change it in MyISAM for profiles and likes ?

@dimalifragis not a bit site : https://mondesensuel.fr/forum

I have a VPS server : 

  • Bi Intel® Xeon®
    E5-2650
    (20 coeurs 3.0 GHz)
  • 3 (3x3.0 GHz)
  • 8 Go ram
  • 6 Go Vswap ssd
  • PHP 7.4

What is DB ?

 

Reply
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

@martin today, it's 2,5 seconds lost with slow querries 🙁

 

Reply
Page 1 / 2