Notifications
Clear all

wpForo 1.x.x slow queries

26 Posts
4 Users
2 Likes
741 Views
dimalifragis
Posts: 1452
(@dimalifragis)
Noble Member
Joined: 2 years ago

I see you use Rocket cache WITH wpForo and this is not what you should do. It has been talked a lot here and also the support has posted several time to exclude ANY caching from wpForo pages.

Also checking your site, it is not small. Maybe use Autoptimize to reduce https calls etc etc.

But for sure exclude caching from wpForo.

(edit: see what goes on in your wpForo page in the capture attached. MANY calls to external services).

Reply
1 Reply
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

@dimalifragis thank you.
So I just need to uncach in wp rocket settings this link : /forum ? (this is the link of wp foro on my website).
It included all links of the forum ?

Reply
dimalifragis
Posts: 1452
(@dimalifragis)
Noble Member
Joined: 2 years ago

This is the official post about caching:

https://wpforo.com/community/faq/wpforo-and-cache-plugins/#post-37150

I'm not familiar with that plugin (it is paid) but i guess ... yes. The "base" page with the shortcode should be excluded.

ย 

Reply
Martin
Posts: 866
Moderator
(@martin)
Support Team
Joined: 6 years ago
Posted by: @mondesensuel

@martin today, it's 2,5 seconds lost with slow querries ๐Ÿ™

1. Click "Mark all read" link in the forum footer.

2. If you have a thousand of users and your wp_usermeta table has dozens or hundreds of thousands of entries then you should find a way to clean your users and make the wp_usermeta table lighter.

3. Change these two table engines to MyISAM:

  • wp_wpforo_profiles
  • wp_wpforo_likes

4. Make sure the following table engines are InnoDB:

  • wp_wpforo_posts
  • wp_usermeta

Make sure all wpForo caches are enabled in Dashboard > Forums > Settings > Features tab.

Reply
2 Replies
Mondesensuel
(@mondesensuel)
Joined: 6 years ago

Trusted Member
Posts: 51

@martin thank you Martin.

How I can clean the forum members ? I have more 4000 members.

You have more 15.000 members and your forum is faster than mine.

Reply
Macky
(@percysgrowroom)
Joined: 3 years ago

Noble Member
Posts: 792

@mondesensuel Bro, I had the same issues as you are having here.

I got rid of all cache plug ins, and got a light theme for my site, generate press was the one i chose.ย 

Then I moved the data bases over the right places and it was perfect. I get less than 2 second page load time now.ย 

Take a look at this post, and i go through what i did to take my site from 8 seconds load time to below 2 seconds, and it was mostly to do with the databases. ๐Ÿ™‚

Hope this helps:

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-have-a-fast-forum/

Reply
Macky
Posts: 792
(@percysgrowroom)
Noble Member
Joined: 3 years ago
Posted by: @martin

Change these two table engines to MyISAM:

This can be done easily if you install the litespeed cache plug in, you can move the databases you need and then delete the plug in, you dont need to keep it after the DBs have moved. I still have no cache plug in on my site at all, and still have very fast load times ๐Ÿ™‚

The databases are the key, get them in the right places and your forum will be much faster

Reply
dimalifragis
Posts: 1452
(@dimalifragis)
Noble Member
Joined: 2 years ago

Getting rid of a cache plugin is NOT suggested for Wordpress. No reason for it, since you can simply exclude any page(s) you need to do so.

If you have wpforo turn to a Wordpress/forum only, i can understand that, but if you have other Wordpress pages/posts/plugins, a caching plugin can make a huge difference.

Reply
1 Reply
Macky
(@percysgrowroom)
Joined: 3 years ago

Noble Member
Posts: 792

@dimalifragis I will reinstall one then lol. Thanks man. With all the work i did to databases my whole site is pretty fast so havent felt the need to get one, as they can be a pain in the ass sometimes lol.

Reply
Page 2 / 2
Share: