Notifications
Clear all

wpForo 1.x.x [Solved] Trouble when removing Social Networks fields in profile

8 Posts
6 Users
2 Likes
1,685 Views
bookreader
Posts: 8
Topic starter
(@bookreader)
Active Member
Joined: 3 years ago

Dear team,

In another forum thread I found some CSS code that will help me remove the Social Networks fields in users' Account settings.  This is the code: .wpf-tr.row-1 {display:none !important;}. However, when I use this code it removes the users' Occupation and Location from their public profile page, even though those fields are still visible and editable in the Account settings page. 

Can you advise me how to prevent the social networks fields from displaying, while allowing the location and occupation? 

Thanks!

7 Replies
1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

Solution is here:

https://wpforo.com/community/how-to-and-troubleshooting-2/editing-profiles-social-media-fields-wp-discord-app/#post-18147

Reply
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @bookreader,

Thank you for using wpForo and for contacting us!

We've just checked the CSS code. In our case, it only hides the Social Networks fields:

.wpf-tr.row-1 {
display: none !important;
}

Please check one more time and make sure there is no extra CSS code in "Custom CSS code" textarea.

Reply
1 Reply
bookreader
(@bookreader)
Joined: 3 years ago

Active Member
Posts: 8

Thanks for your reply! ChrisW below helped clarify what I was having trouble with. His solution nailed it!

Reply
CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago
Posted by: bookreader

Dear team,

In another forum thread I found some CSS code that will help me remove the Social Networks fields in users' Account settings.  This is the code: .wpf-tr.row-1 {display:none !important;}. However, when I use this code it removes the users' Occupation and Location from their public profile page, even though those fields are still visible and editable in the Account settings page. 

Can you advise me how to prevent the social networks fields from displaying, while allowing the location and occupation? 

Thanks!

 

Posted by: Sofy

Hi @bookreader,

Thank you for using wpForo and for contacting us!

We've just checked the CSS code. In our case, it only hides the Social Networks fields:

.wpf-tr.row-1 {
display: none !important;
}

Please check one more time and make sure there is no extra CSS code in "Custom CSS code" textarea.

 

 

Hi @sofy . I think what @bookreader is having issues with is that the code,

.wpf-tr.row-1 {
display: none !important;
}

only hides the social networks from the Member Account Settings. It also hides the Social Networks (except for the label, which still appears empty in the Public Profile)

The above code also simultaneously, in the Public Profile, hides the Location and the Timezone.

I wrote Custom Code for it many months ago (because I learned it and figured it out) and I never got to share those here (I thought I did, I guess I got irked by a poster who went out of his way to tag me and write that I wasn't too elegant with my tips I laboriously typed for someone else, and I ended up not sharing the custom code below! LOL!). Well, I'm sharing it now. I hope Sofy, that you and your Support Team don't mind me sharing my codes and tips here. I don't worry about elegance when I try to help. 🙂 

@bookreader - It's not a "bug" per se, because it is a customization, okay?  So I'll share with you what I did on my forum.  🙂 

Here's how to hide the Member Account Settings - Avatar URL

.wpf-field-type-avatar li:nth-child(2) {
display: none;
}

Here's how to hide the Member Account Settings - Title

.wpf-field-name-title.wpf-field-required {
display: none !important;
}

Here's how to hide the Member Account Settings - About Me

.wpf-field-type-textarea.wpf-field-name-about {
display: none !important;
}

Here's how to hide the Member Account Settings - Website

.wpf-field-type-url.wpf-field-name-site {
display: none !important;
}

Here's how to hide the Member Account Settings - Occupation

.wpf-field-name-occupation{
display:none !important;
}

And for the Social Media Fields!

Here's how to hide the Member Account Settings - Facebook

.wpf-field-type-url.wpf-field-name-facebook {
display: none !important;
}

Here's how to hide the Member Account Settings - Google Plus

.wpf-field-type-url.wpf-field-name-gtalk {
display: none !important;
}

Here's how to hide the Member Account Settings - AOL IM

.wpf-field-type-text.wpf-field-name-aim {
display: none !important;
}

Here's how to hide the Member Account Settings - MSN

.wpf-field-type-text.wpf-field-name-msn {
display: none !important;
}

Here's how to hide the Member Account Setting - Twitter

.wpf-field-type-url.wpf-field-name-twitter {
display: none !important;
}

Here's how to hide the Member Account Settings - Yahoo

.wpf-field-type-text.wpf-field-name-yahoo {
display: none !important;
}

Here's how to hide the Member Account Settings - ICQ

.wpf-field-type-text.wpf-field-name-icq {
display: none !important;
}

Here's how to hide the Member Account Settings - Skype

.wpf-field-type-text.wpf-field-name-skype {
display: none !important;
}

And after you've "hidden" all that, the field "Social Network" still shows on the Public Profile, so..

Here's how to hide the empty Social Media field from appearing on the Member Public Profile

.wpf-field-type-html.wpf-field-name-html_soc_net {
display: none !important;
}

I chopped up the code this way, because other people might want to show some and then hide some.

The above code in it's entirety just displays:

In the Member Account Settings

  1. Display Name
  2. Nickname
  3. Email
  4. Avatar
  5. Location
  6. Timezone
  7. Password

In the Public Profile

  1. Location
  2. Timezone

I hope this helps someone. 🙂

And @bookreader - if the above tips solves your Original Post Issue, please don't forget to click the "Solved" button, so that the Support Team can close the topic. (So you and I will not receive automated emails 10 years from now, if someone posts something under this Topic 🙂 ).

Thank you Sofy and your marvelous Support Team for all the help you extend to everyone out here! (It's contagious! You're all awesome! 🙂 )

 

Disclaimer:  This Custom CSS Code is what I use in my forum.  It works for me, it might not work for you.  I'm allergic to grouchy people and I get attacks of "I-will-ignore-you-if-you-are-rude-or-arrogant" which results in I will not log-in and share tips-ti-tis.  So be nice when asking, and learn to thank people who try to help.  Even if their tips don't help.  They spent time typing up stuff and trying.  Parental guidance and patience is advised.  🙂 

Reply
1 Reply
bookreader
(@bookreader)
Joined: 3 years ago

Active Member
Posts: 8

@ChrisW, perfectly elegant, thank you! You exactly clarified the issues I was having and the solution you provided is precisely what I needed. I'm very grateful!

Reply
chatmehard
Posts: 7
(@chatmehard)
Active Member
Joined: 7 months ago

Hey guys, do I have to put these lines of code into the css file of the plugin or into the theme file editor?

Reply
1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1907

Hi @chatmehard,

Go to Dashboard > Forums > Settings > Styles Tab and insert the CSS codes in Custom CSS Codes field.

Reply
Share: