Notifications
Clear all

wpForo 1.x.x [Closed] Usergroups - confused

11 Posts
3 Users
0 Likes
583 Views
Posts: 347
Topic starter
(@danniee)
Honorable Member
Joined: 4 years ago

Hi,

I use both Wpforo and wpdiscuz and wonder if there is a way to synch the usergroups so I don't have to set usergroups separately for both? I have been trying to play around with the settings (in wpforo and profiles) but they don't really make any sense to me.

For example, I have managed to create a group called "Reps" but it will display both "New Member" and secodary group "Reps" in the forum. If I deactivate secondary group "Reps" disappears. Also, the colour of the title is just transparent even when I change group colour "Reps" to blue.

Thanks

10 Replies
Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

@danniee,

wpDiscuz is a comment plugin and it displays WordPress User Roles not Usergroups. wpForo is a forum plugin, and it has its own Usergroups. User Roles are not Usergroup. Please read attentive this FAQ topic: https://wpforo.com/community/faq/wordpress-user-roles-wpforo-usergroups-and-forum-accesses/

Posted by: @danniee

For example, I have managed to create a group called "Reps" but it will display both "New Member" and secodary group "Reps" in the forum.

The "New Member" is not an Usergroup, it's a User title. You can hide/show User Titles and Usergroups in Dashboard > Forums > Settings > Members Tab under the user Reputation table.

 

So, because the User Roles are not usergroups then there is no way to show them with the same color or with the same name. The plugins are also different plugins, and they don't use the budges of each other.

Posts: 347
Topic starter
(@danniee)
Honorable Member
Joined: 4 years ago

Ok, thank you for clarifying that. Since the plugins are from the same company I figured their functionality were connected somehow.

Can you please explain why I cannot change the color of the usergroup I have created? It does say "Rep" but the color displays white even though I have picked blue. Also, how do I only display one usergroup and not also "new member"? Thank you.

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4143

@danniee,

I think you'd like to change the background colour of the labels, wouldn't you? If so please follow the solution provided here: 

https://wpforo.com/community/postid/14427/

Posts: 347
Topic starter
(@danniee)
Honorable Member
Joined: 4 years ago

Yes, I'd like to change the color of the little square. I check the link and tried adding this but nothing happens:

#wpforo #wpforo-wrap .wpf-member-title.wpfut.wpfug-6 {background-color: #000000 !important;}

My newly created usergroup has ID 6.

Also, is there a way to remove "new member" and only display "official rep" (my new usergroup)?

5 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4143

@danniee,

Please leave some example URL to allow us to chekc the issue. 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478

@danniee,

You can hide the "new member" reputation title in Dashboard > Forums > Settings > Members Tab. This is controlled by Usergroup, so you should uncheck the usergroups that should not have reputation title on frontend:

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478
Posted by: @danniee

Yes, I'd like to change the color of the little square. I check the link and tried adding this but nothing happens:

#wpforo #wpforo-wrap .wpf-member-title.wpfut.wpfug-6 {background-color: #000000 !important;}

Please delete your cache and press Ctrl+F5 on forum front end.

(@danniee)
Joined: 4 years ago

Honorable Member
Posts: 347

@robert I did, but it still didn't work.

(@danniee)
Joined: 4 years ago

Honorable Member
Posts: 347

@robert thank you for your help. However, I can only make it display "Member" alone or "Member" AND "Official Rep", not ONLY "Official Rep". Tried several combinations in the settings and nothing gives me the desired result :/

Posts: 347
Topic starter
(@danniee)
Honorable Member
Joined: 4 years ago

This is all so confusing. I changed the color of the usergroup box and it didn't change for the user in the front end (posts). I go in to the users profile and hit save and only then does the colour change in the front end. But for some reason the box has blue background (correct) but grey text. In my admin usergroup box it's red with white text by default. I don't see anywhere to change the text colour.

I don't get why things like these have to be so complex and involve css etc. What does the usercolor option in the front end settings do when it doesn't work and you have to change the color in the css settings? I'm super confused by this.