Notifications
Clear all

wpForo 1.x.x [Solved] WP-Admin login highjacked

2 Posts
2 Users
0 Likes
507 Views
Posts: 7
Topic starter
(@atomz)
Active Member
Joined: 3 years ago

When I logged into my WP-Admin panel, the url was changed to 
https://atomz.pro/tec-tocc/forum/?foro=signin&redirect_to=https%3A%2F%2Fatomz.pro%2Ftec-tocc%2Fwp-admin%2F, and redirected to the forum login.
I would prefer that this didn't happen. Yes, it still logged me in to the admin area, but also showed the forum screen by default. (I would rather the plugin of another plugin was displayed)

Here's how I have things set up. I have a plugin (ARMember) that protects the site as a membership site. When people subscribe via Stripe, it creates a member in the above site AND places them within the forum user database (since it is a shared WP database)

ARM also requests their details up front, (name, last name, username, password, email) so I've got to look into NOT sending a forum email to request them to set a password. (Most of the forums will be hidden by the membership site, so don't need a seperate login) The few that are public will go through the standard registration / set password proceedure

But my most important problem at present is the redirect, and turning it off (.httaccess maybe?)

My only 'complaint' so far is that the forum width cannot be changed. Because the screen area real esstate is only half screen width (due to fancy borders / sidebar/ social icons) the header menus get split over two lines, which looks odd. No prob. Changing the theme and using a slide in side menu plugin

1 Reply
Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

@atomz,

wpForo don't allow users to go to /wp-admin/ directory so it redirects the logn page. You just need to disable this function in Dashboard > Forums > Settings > Features Tab and disable the "Replace Login Page URL to Forum Login Page URL" option. 

Don't do any changes in any file, just disable that option.