Notifications
Clear all

wpForo 1.x.x wpForo and SyntaxHighlighter Evolved

21 Posts
5 Users
5 Likes
3,643 Views
Florian
Posts: 92
(@florian)
Trusted Member
Joined: 4 years ago

@labradorman @robert

I was actually able to get the TinyMCE codesample plugin into the wpForo editor. It doesn't apply the syntax highlighting but it's a nice way to add blocks of code.

https://www.tiny.cloud/docs/plugins/codesample/

Reply
nando4
Posts: 111
(@nando4)
Estimable Member
Joined: 6 years ago
Posted by: @labradorman

Dear Sofy,

Thank you so much for your kind and great help! It now works almost perfectly. Except with the same issue as mentioned in 

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-use-wpforo-with-syntaxhighlighter-evolved/

That is, the sign '&' and '>=' are now rendered incorrectly as '&' and '>'. Is there any way to deal with this wrong renders ? (I try to search for a simple solution, but couldn't find it)

 

@Robert, @Sofy, can you share the solution provided to @labradorman in preventing what looks to be html encoding of special chars when integrate this plugin with wpforo.

Reply
nando4
Posts: 111
(@nando4)
Estimable Member
Joined: 6 years ago
Posted by: @nando4

 

@Robert, @Sofy, can you share the solution provided to @labradorman in preventing what looks to be html encoding of special chars when integrate this plugin with wpforo.

@Robert, @Sofy, any reply to my last query?

Reply
7 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@nando4

To tell the truth, developers don't remember the changes they had done. Please send the admin login details to info[at]gvectors.com email address. I'll ask developers to check and provide the solution for you. 

Reply
nando4
(@nando4)
Joined: 6 years ago

Estimable Member
Posts: 111

@sofy

email was sent several days ago. No reply as yet.

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@nando4

Could you please send one more time and let us know. We don't see an email with such content. 

Reply
nando4
(@nando4)
Joined: 6 years ago

Estimable Member
Posts: 111

@sofy

Just resent the email now. Look for an email from nando4*** (at) gmail (dot) com.

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

Thank you @nando4,

I'm really sorry but this issue doesn't come from wpForo plugin. You should contact the SyntaxHighlighter Evolved plugin and ask let them know about the issue. 

Also, as far as we see the wpForo add-ons are not updated. We highly recommend you update wpForo add-ons to the latest versions.

Reply
nando4
(@nando4)
Joined: 6 years ago

Estimable Member
Posts: 111

@sofy

labradorman speaks about &gt and &amp conversions of > & which appear to have been solved. Or was that outstanding issue never solved?

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@nando4

We've asked labradorman to contact the SyntaxHighlighter Evolved plugin support and let them know about the issue. The issue doesn't come from wpForo plugin and cannot be fixed by wpForo side. 

I'm really sorry, but I don't know is the issue solved or not.

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

wpForo Syntax Highlighter addon is now released:

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-use-wpforo-with-syntaxhighlighter-evolved/#post-49222

Reply
Page 3 / 3