Notifications
Clear all

wpForo 1.x.x WPForo with Varnish

3 Posts
3 Users
0 Likes
761 Views
quentinb
Posts: 1
Topic starter
(@quentinb)
New Member
Joined: 3 years ago

Hello there,

Got a little issue with your plugin working along with Varnish. 
Obviously here's what I got while testing if Varnish is properly working on my site : (attach file)

I tried to disabled features from wpForo or find a way to limit the set-cookies to only Forum pages but nothing works so far (maybe I'm missing something). 

Here's the "curl -I myurl.com" result :

HTTP/2 200 

cache-control: public, max-age=600

content-type: text/html; charset=UTF-8

link: < https://dev-mysite.pantheonsite.io/wp-json/>; rel="https://api.w.org/"

link: < https://dev-mysite.pantheonsite.io/>; rel=shortlink

server: nginx

set-cookie: SESSacc6532b7fec69a7ae2d4467de9b70dd=d77b19681c22f821ffdc8ad59c2035e9; expires=Mon, 08-Jul-2019 12:12:13 GMT; Max-Age=0

set-cookie: SSESSacc6532b7fec69a7ae2d4467de9b70dd=b42337a5ef828f72f75c08a71173a149; path=/; domain=.dev-mysite.pantheonsite.io; secure; HttpOnly

x-pantheon-styx-hostname: styx-fe3-85f59bbfdd-svp59

x-styx-req-id: 4936abdb-ff17-4c17-99fd-1eb35ab94602

accept-ranges: bytes

accept-ranges: bytes

via: 1.1 varnish

age: 0

accept-ranges: bytes

accept-ranges: bytes

date: Mon, 08 Jul 2019 12:12:14 GMT

via: 1.1 varnish

age: 0

x-served-by: cache-mdw17368-MDW, cache-lcy19243-LCY

x-cache: MISS, MISS

x-cache-hits: 0, 0

x-timer: S1562587933.245035,VS0,VE761

vary: Accept-Encoding, Cookie, Cookie

x-robots-tag: noindex

 

So Age: 0 and there's a Max-Age set to 0 too. If I deactivate wpForo, varnish is just working fine. 
I'm not really a WordPress expert and it's pretty much a nightmare to work on 😖.

I've checked most of the relative subject in your forum/wp-forum but didn't found any way to fix it properly so far.

Is there any 'known' fix for this kind of issue? Am I missing something?

Thanks,
Quentin

 

 

2 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @quentinb,

Thank you for contacting us.

You should exclude wpForo page (e.g. /community/*) from caching plugins. wpForo has own cache system. It comes with four different built-in caching systems.

Also, wpForo has a filter that allows reducing the cookies:

wpforo_cookie_max_logged_topics.

You can also fully disable Forum Cookies. The option is located in Dashboard > Forums > Tools > Privacy & Rules admin page.

Reply
Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 7 years ago

I think Varnish is not controlled by a WP Plugin and we are not talking about a caching plugin.

So, your hosting provider could help more on this, on how to exclude wpForo pages and test.

Reply
Share: