Notice: Trying to a...
 
Notifications
Clear all

[Solved] Notice: Trying to access array offset on value of type bool

35 Posts
4 Users
0 Likes
482 Views
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

@s474n,

Somehow the update was not completed, and the data have not been added in the database. The database fixer tool allowed you to create tables and fix table changes, but you still need to add the first board information. Please execute the following SQL, then go Dashboard > wpForo > Boards > Edit Board and manage the forum title, slug (URL), description.

SET sql_mode='NO_AUTO_VALUE_ON_ZERO';
INSERT INTO `wp_wpforo_boards` (`boardid`, `title`, `slug`, `pageid`, `modules`, `locale`, `is_standalone`, `excld_urls`, `status`, `settings`) VALUES
(0, 'Forums', 'community', 5, '{\"tags\":true,\"subscriptions\":true,\"mentioning\":true,\"follows\":true,\"notifications\":true,\"logging\":true,\"seo\":true,\"antispam\":true,\"akismet\":true,\"rss\":true,\"social\":true,\"revisions\":true,\"bookmarks\":true,\"wpforo-user-custom-fields\":true,\"wpforo-private-messages\":true,\"wpforo-mycred\":true,\"wpforo-topic-prefix\":true,\"wpforo-tenor\":true,\"wpforo-giphy\":true,\"wpforo-advanced-attachments\":true,\"wpforo-embeds\":true,\"wpforo-topic-custom-fields\":true,\"wpforo-syntax-highlighter\":true,\"wpforo-cross-posting\":true,\"wpforo-ad-manager\":true,\"wpforo-polls\":true,\"wpforo-emoticons\":true,\"wpforo-woocommerce-memberships\":true,\"go2wpforo\":true}', 'en_US', 0, '[]', 1, '{\"title\":\"Forum\",\"desc\":\"Discussion Board\"}');
Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

Make sure you've copied the whole SQL. Don't add line-breaks or spaces, just copy and execute it as is.

Reply
S474N
Posts: 17
Topic starter
(@s474n)
Active Member
Joined: 4 months ago

Executed, it creates first line, but in admin have more errors with creating new table with error "CREATE command denied to user....".Β 

Reply
S474N
Posts: 17
Topic starter
(@s474n)
Active Member
Joined: 4 months ago

Tested with admin login/pass to DB and new errors. It wants to create tables with _1.

Β 

Reply
4 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

please provide admin access to your website, send the credentials to info[at]gvectors.com, mention this topic in the email, mention your website as well and let us know here that you have sent the email.

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris sent registration mail with admin access.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

didn't get the email.

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris so again πŸ™‚

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

@s474n,

Please update to wpForo 2.0.6 version, then go to Dashboard > wpForo > Tools > Database Tables admin page and solve the board issue again by clicking the [Solve problems] button or using the SQL code, the SQL should be executed all together if the problem-solving button doesn't help.

Reply
15 Replies
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@robert doesn't have Tools under wpForo. Chris has admin login, can he try it?

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

Use the SQL mentioned by @robert, as the wpForo Database Tables Tab doesn't see any issue.

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris so there is two boards:

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@s474n ,

Please delete the one with boardid=1 an "not found" words. Then delete all caches and wpForo cache in wpForo > Overview admin page.

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@robert done, seems to be OK. What do you mean?

https://www.iotcz.cz/forum/

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@s474n,

I see all is ok.

And put this CSS code in wpForo > Settings > ColorsΒ  Styles > Custom CSS Code textarea to make the forum width larger:

.wpforo .entry-content > :not(.alignwide):not(.alignfull):not(.alignleft):not(.alignright) {
  max-width: 1200px;
}
Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@robert it looks better, but where is user menu (user settings,..)?

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

go to Dashboard > Appearance > Menus, check wpForo Navigation(wpForo Menu).

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris it's not menu with user settings, etc.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

I don't follow you, can you provide and screenshot?

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

Open the Menu Page,

From Select a menu to edit: field, Select wpForo Navigation,

Press On Custom Links

Insert one of the below shortcodes in the URL field,

  • /%wpforo-profile-account%/
  • /%wpforo-profile-activity%/
  • /%wpforo-profile-subscriptions%/

Set the Page name in field.

Move the New Created Custom Link under My Profile Page.

Check the IMG:

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris have it here, twice.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2335

@s474n,

You have 2 boards?

Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@chris no, only one. Don't know, why is twice and doesn't work.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

@s474n,

Please navigate to wpForo > Boards and delete the second board if that was not created by you. The default board has boardid=0, other boards should be deleted if they have created automatically.

Then delete all caches and find the real forum URL in the same admin page (default board URL).

Read this doc to find and change the forum URL: https://wpforo.com/docs/wpforo-v2/getting-started/forum-page/change-forum-page/

Reply
1 Reply
S474N
(@s474n)
Joined: 4 months ago

Active Member
Posts: 17

@robert all done πŸ˜‰ now have problem with wpforo main menu. Please see above.

Reply
Page 2 / 3