Notifications
Clear all

[Closed] 2 forum pages created when wpForo installed

12 Posts
3 Users
0 Reactions
734 Views
Posts: 13
Topic starter
(@annealex)
Active Member
Joined: 1 year ago

I installed wpForo and it created two forum pages. Is that right? I deleted the second one and it messed things up so I restored it.

https://climateandeconomy.com/community/

https://climateandeconomy.com/community-2/

11 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @annealex,

Why do you create 2 Forum Pages, if you are using one Board?

Posts: 13
Topic starter
(@annealex)
Active Member
Joined: 1 year ago

I didn't create two forum pages - the plugin did. See attached. (I renamed the first one to Discussion Board.) I deleted the second one and everything crashed, so I restored it and everything works.

9 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@annealex,

The reason that everything crashed should be that you have deleted the page which is connected to the board with ID.

(@annealex)
Joined: 1 year ago

Active Member
Posts: 13

@chris I'm sorry I don't understand.

"Crush"?

I have deleted the (what?)"

Thanks.

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@annealex,

My bad, just edited the post.

Make sure you delete the page whose ID doesn't match the board ID.

And the Page, which is connected to the Board, should have [wpforo] shortcode in the content.

(@annealex)
Joined: 1 year ago

Active Member
Posts: 13

@chris Thanks for your reply. Both pages have the shortcode. See attached. When I deleted the community-2 page, it all crashed. So I restored it and the board is working. I read somewhere in the documentation but can't find it at the moment that said two pages would be created...? So I am thinking I need to just leave them both...?

(It won't let me attached two images, but they are the same except for the URL).

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@annealex Hi, what "it all crashed" means. What was the error?

Just delete the "community-2"

(@annealex)
Joined: 1 year ago

Active Member
Posts: 13

@dimalifragis When I deleted community-2 the forum and everything was gone. So I restored it. Is there any problem with just keeping community-2?

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@annealex Again,your correct page is "community". Delete the "community-2" page and try THEN to find where else "community-2" is present. Check Board settings.

And nothing is gone. Nothing. You have some wrong setting, most probably in your board settings.

See my settings (but for me the page is forums and not community). See also the page ID, is your page ID the same with the page "community" ?

(@annealex)
Joined: 1 year ago

Active Member
Posts: 13

@dimalifragis Thansk! I think I figured it out. The actual discussion page had the page id of the other page. So I changed the page id and when I deleted the second page, everything is fine.

Yeah!!! Thanks so much for your help.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@annealex The page ID is shown in your Board settings and if you CLICK in the Page id in there, it will OPEN for EDIT that page. So you will see what page is that.

But just delete the community-2 page.