Notifications
Clear all

[Solved] Login not possible, wrong rewrite rules

2 Posts
1 Users
0 Likes
108 Views
dieter_e
Posts: 7
Topic starter
(@dieter_e)
Active Member
Joined: 3 months ago

After installing the plugin it worked for some time quite well, then I deinstalled UsersWP (AyeCode LtD) and after deleting the pages for profil management of UsersWP (for Login, Register, Profile, ..) I can no longer login with wpforo. I can open the community page ('forum') but can't Login, Register, and others. Instead I get a wpforo page with the warning: Nothing Found!
with the URL: https://ungeborene.de/login?redirect_to=https%3A%2F%2Fungeborene.de%2Fforum   

I get this message on debug page: 

wpForo detected wrong rewrite rules, please navigate to wpForo > Overview admin page, scroll down, click the [Soft Flush Permalinks] button, if the issue is not fixed, please click the [Hard Flush Permalinks] button.

Wrong revrite rules (current pageid is 14517):

  • (?:([a-z]{2,3})/)?member(?:/|$).*$  |  index.php?lang=$matches[1]&page_id=14518
  • (?:([a-z]{2,3})/)?change-password(?:/|$).*$  |  index.php?lang=$matches[1]&page_id=14518
  • (?:([a-z]{2,3})/)?login(?:/|$).*$  |  index.php?lang=$matches[1]&page_id=14518
  • (?:([a-z]{2,3})/)?register(?:/|$).*$  |  index.php?lang=$matches[1]&page_id=14518
  • (?:([a-z]{2,3})/)?members(?:/|$).*$  |  index.php?lang=$matches[1]&page_id=14518

I performed Soft Flush and Hard Flush on Overview admin page
the file .htaccess doesn't show any (new) entry like "rewrite_rules_bk_{sec}" or a "wp_options" table,
but .htaccess-bk-{sec} files were created,
I deleted broken internal links,
I deinstalled and re-installed wpforo,
I edited the Board (there is only 1 Board with ID 0, pageid 14517), followed by hardlink flush. 
No improvement.

Just Logout by wpforo menu is possible (after login by wp-login )

wpForo Version
2.0.9
WordPress Version
6.1
1 Reply
dieter_e
Posts: 7
Topic starter
(@dieter_e)
Active Member
Joined: 3 months ago

Problem is solved.

I changed the pageid of the only existing Board, saved it,
edited the Board again to the first value, and saved again.

Now the wpForo provides working Login, Registration, Profile and Account links.