Notifications
Clear all

[Solved] Blog Post Author Links Not Resolving Correctly

24 Posts
8 Users
6 Likes
321 Views
Tutrix
Posts: 759
(@tutrix)
Prominent Member
Joined: 2 years ago

the same problem
when the forum profile is activated, all author links in wordpress don't work anymore, either "Anonymous" (User_Nicename) or "0" (ID)

https://www.screencast.com/t/JcyvLpPm

Reply
VereK
Posts: 388
(@verek)
Honorable Member
Joined: 5 years ago

@dimalifragisย 

Wordpress User Dashboard - as mention already, others are having the problem from other sources profile links in blog posts, but that all comes back to the Wordpress User Dashboard for example: https://wpforo.com/community/postid/68443/

The only way I could get a pseudo link to author/username/ is by setting the profile page in WPForo/Setting/Member Profile to "default" which does not work at all because the permalink in WPForo/Settings/General is set to /participant

and seems to work fine. It doesn't go to any profile.

I don't understand this statement, how is it working fine if it does not go to any profile? It is supposed to go to whatever you set as forumbaseurl/profile/username - the way it has always done in 1.x.x.x when the profile page was set "wpforo" in Dashboard/Forums/Settings/Features

Reply
1 Reply
dimalifragis
(@dimalifragis)
Joined: 2 years ago

Noble Member
Posts: 1638

@verek I understand that this is somehow an issue (that has been found and will be resolved).

Still for ME, there is NO 404 anywhere, as the OP posted. I have NO 404 anywhere after wpforo2.

Reply
BlackRaz
Posts: 53
Admin
(@blackraz)
Contributor
Joined: 6 years ago

Hi there,

We have already catch this issue and it will be solved in the next version. ๐Ÿ™‚

Reply
Robert
Posts: 9713
Admin
(@robert)
Support Team
Joined: 7 years ago

@tutrix, @tptclan, @eel,

Please update to wpForo 2.0.5 version. This issue should be fixed.

Reply
1 Reply
VereK
(@verek)
Joined: 5 years ago

Honorable Member
Posts: 388

@robertย 

Confirmed fixed for me in 2.05

Reply
eel
Posts: 79
 eel
(@eel)
Estimable Member
Joined: 2 years ago

This is not resolved. The author links on the front page take people to the forum profile rather than their author page, which pulls up all their posts.

Thanks!

Reply
3 Replies
RealAct
(@realact)
Joined: 4 years ago

Estimable Member
Posts: 160

@eel hmmm If I'm understanding you right, I think that's the way it has always been, if you click on the author link from the front page it should take you to their forum profile. In fact, that's what the integration should be.

The regular WordPress behavior with no WPForo or Profile Builder plugin is taking you to that page with all the Author's articles.

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9713

@eel,

The author URL can be kept or changed to wpForo forum profile using "Profile Page" option in wpForo > Settings > Member Profile admin page. Just change it to "wpForo" if you want to redirect all author URLs to their forum profiles, or keep the "Default" if you want to keep them separate.

Reply
eel
 eel
(@eel)
Joined: 2 years ago

Estimable Member
Posts: 79

@robert perfect!ย  This resolved the problem. Thanks for your help!

Reply
Page 2 / 3
Share: