Notifications
Clear all

[Closed] Cache issue for users when logging in

10 Posts
3 Users
1 Likes
785 Views
Posts: 350
Topic starter
(@danniee)
Honorable Member
Joined: 5 years ago

Hi,

Been having this issue for probably a year and I don't know how to solve it. It only seems to be an issue when using an iOS device.

Some users have a problem logging in. It doesn't happen all the time but it suddenly starts happening for them. It looks like they are logged in but when they go to another page they are logged out and vice versa. Typical cache issue.

I am pretty sure this is related to using WP Rocket feature "cache logged in users". I tried reaching out to them but they couldn't fix it.

I have tried pretty much everything. I have excluded the forum url's etc.

9 Replies
dimalifragis
Posts: 2572
(@dimalifragis)
Famed Member
Joined: 4 years ago

In general (sitewide) it is a bad practice to CACHE logged in users. Very bad.

2 Replies
(@danniee)
Joined: 5 years ago

Honorable Member
Posts: 350

@dimalifragis it hasn't been for me aside from this particular issue only some users experience. This is a great feature WP Rocket has.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2572
Posted by: @danniee

@dimalifragis it hasn't been for me aside from this particular issue only some users experience. This is a great feature WP Rocket has.

Nope. Not WP Rocket specific, but in all plugins that offer caching for logged in users.

Still, if it works for you then ok. But it seems it doesn't 🙂

Posts: 350
Topic starter
(@danniee)
Honorable Member
Joined: 5 years ago

Maybe will have to turn it off. We'll see if there is a chance to solve this 🙂

dimalifragis
Posts: 2572
(@dimalifragis)
Famed Member
Joined: 4 years ago

I have seen so many time users with session problems due to caching for loggedd in....

1 Reply
(@danniee)
Joined: 5 years ago

Honorable Member
Posts: 350

@dimalifragis hm, yes I can imagine. Might have to deactivate this feature though it's frustrating since the issue only happens to a small fraction of users and only those using iOS devices.

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

@danniee,

With wpForo 2.0 you should exclude more paths from your cache plugin, please make sure this instruction has been done properly:

  1. Navigate in Dashboard to WP Rocket > Advanced Rules Tab
  2. Scroll down to "Never cache (URLs)" option
  3. Insert the URL path(s) of your forum page(s) one per line with wildcard (.*) in the option textarea:
    /community/(.*)
    /participant/(.*)
    /sign-up/(.*)
    /sign-in/(.*)
    /change-password/(.*)
  4. Save it and delete all caches.
1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

If the forum path /community/ and the member's page path /participant/ have been changed, then you should insert the correct paths.

Also make sure the login and register paths are correct as well:

/sign-up/(.*)
/sign-in/(.*)
Page 1 / 2