Notifications
Clear all

wpForo 1.x.x [Closed] Disable Email Notification on New Reply

15 Posts
4 Users
2 Reactions
1,149 Views
Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

Hi,

How to disable email notification when someone replies?

What I already did are disabling:

  • Enable Subscription Confirmation
  • Topic subscription option on post editor 
  • Topic subscription option on post editor - checked/enabled

Not sure if this is the "Enable User Notification". Let me know please.

For context, the hosting is advising me to do that since it makes our site slow. My initial traffic expectation were way below.

14 Replies
Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

Just found it on the Email tab. Thank you!

Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

Oh wrong, that's the User Mentioning that I disabled.

There's no option to disable "New reply notification email subject:".

Let me know if there's one please. Thanks!

10 Replies
Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@macaronisalad,

There's no option to disable "New reply notification email subject:"

I'm sorry but there is no way to do this.

More info here: https://wpforo.com/docs/root/wpforo-settings/emails-settings/#admin-notification

(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

@alvina really? That's hard to believe. Even a code or something that can do that anything.

Those emails are causing my site to lag because of too much volume. Every time someone replies to a thread. Everyone is getting an email notification which causes lag. Please check the image that I sent for context.

The server from my hosting can't handle it.

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@macaronisalad,

Please navigate to the Subscription page and make sure the "Subscribe to all new topics and posts" is unchecked. And he/she is unsubscribed for the current topic.

https://www.screencast.com/t/ojxmmIbeo69X

(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

@alvina Thanks for your reply but that isn't the problem. 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4493

@macaronisalad,

We may suggest you use the following code:

remove_filter('wpforo_after_add_post', 'wpforo_topic_subscribers_mail_sender', 13);

Just note: in this case, the users will not receive an email for replies even if they've subscribed to this topic. 

Users will get an email in case of registration, mentioning, etc. They'll just not receive the emails for the new replies.

(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

@sofy awesome. This is what I'm looking for.

Sorry for this noob question but where should I put this code? on the style section?

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4493

@macaronisalad,

the code should be added in the currently active theme functions.php file. 

(@macaronisalad)
Joined: 4 years ago

Eminent Member
Posts: 30

@sofy added. Thank you!

(@bbbos)
Joined: 4 years ago

Active Member
Posts: 8

@macaronisalad

Hi can you explain please how did you edit it? thank you

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@bbbos,

Please follow this doc: https://www.wpbeginner.com/beginners-guide/beginners-guide-to-pasting-snippets-from-the-web-into-wordpress/

Posts: 30
Topic starter
(@macaronisalad)
Eminent Member
Joined: 4 years ago

Additional question:

Does this code still works? or there is another way to not let editors see admin bar for wordpress.

function my_admin_bar_control_function() {
if (current_user_can('administrator') || current_user_can('editor') || current_user_can('author') ) {
show_admin_bar(true);
} else {
show_admin_bar(false);
}
}
add_action('init', 'my_admin_bar_control_function', 20);

Thanks!
1 Reply
Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1867

@macaronisalad,

Sure the code works fine. It allows you to enable the admin bar for editors without enabling for all members. In case if you want to show the admin bar only for admins, you just need to disable the "Show Admin Bar for Members" options. The option is located in the Dashboard > Forums > Settings > Features admin page.

More info here:  https://wpforo.com/docs/root/wpforo-settings/features/

The related topic here, please check it out:  https://wpforo.com/community/how-to-and-troubleshooting-2/admin-bar-for-editors-custom-code/#post-16791