Notifications
Clear all

wpForo 1.x.x [Closed] Exclude page URLs Issue

23 Posts
3 Users
8 Likes
2,031 Views
Muhammad Umar Farooq
Posts: 32
Topic starter
(@pkheart)
Eminent Member
Joined: 4 years ago

I am facing an issue with WPforo, I enabled "Turn Wordpress to WPforo" , in Exclude page URLs section I entered desired urls to be accessed and they are working fine. But there is an issue as i am using "Better Messages" for Chatting and it uses different slug for every new message (?new message, ?bulk message, ?thread_id=1,?thread_id=2 .... and so on)

how to give access all addresses under this address( https://discuss.pkheart.com/vu/chat/)

Topic Tags
22 Replies
2 Replies
Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32
Posted by: pkheart

I am facing an issue with WPforo, I enabled "Turn Wordpress to WPforo" , in Exclude page URLs section I entered desired urls to be accessed and they are working fine. But there is an issue as i am using "Better Messages" for Chatting and it uses different slug for every new message (?new message, ?bulk message, ?thread_id=1,?thread_id=2 .... and so on)

how to give access all addresses under this address( https://discuss.pkheart.com/vu/chat/)

Can anybody help me that how to give access all addresses under a page (  https://discuss.pkheart.com/vu/chat/

CrisW
(@crisw)
Joined: 4 years ago

Reputable Member
Posts: 281
Posted by: pkheart
Posted by: pkheart

I am facing an issue with WPforo, I enabled "Turn Wordpress to WPforo" , in Exclude page URLs section I entered desired urls to be accessed and they are working fine. But there is an issue as i am using "Better Messages" for Chatting and it uses different slug for every new message (?new message, ?bulk message, ?thread_id=1,?thread_id=2 .... and so on)

how to give access all addresses under this address( https://discuss.pkheart.com/vu/chat/)

Can anybody help me that how to give access all addresses under a page (  https://discuss.pkheart.com/vu/chat/

Hi @pkheart . I think the chat errors or slugs issue is a "Better Messages" plug in issue and not a wpForo issue.

I checked your site and I noticed that

Your forum location is at:
https://discuss.pkheart.com/vu/?wpforo=signup

And your chat is at:
https://discuss.pkheart.com/vu/chat/

I don't know if I am understanding you correctly...

"Can anybody help me that how to give access all addresses under a page?"

But what I do understand is the "Conflict" of your chat plugin with wpForo.  I experienced the same before so I will share with you what I did to make it work.

I've noticed you have a whole lot of posts already, and that is fine. Impressive courses!  🙂  My suggestion below worked for my many forum posts as well.  So you can try it, and see if it works for you too.

I think and suggest that you can try and do a "workaround" instead, so that you can use BOTH wpForo and the chat software you are using.

Steps:
1) Go to Forum Settings
2) Under the "General Tab", UNCHECK the box that says: "Turn WordPress to wpForo"
3) Then click the blue "UPDATE OPTIONS" button at the bottom.

4) Then go to WP Dashboard, create a New WP Page call it "Forum-Page"

type the wpForo shortcode on this page

[wpforo]

click Publish.

5) Then create another New WP Page, call it "Chat-Page"

type the chat shortcode on this page (I don't know the shortcode to your chat plugin :-))

click Publish.

6) Go to WP Dashboard
7) "Settings"
8) "Reading Settings"
9) Under "Your homepage displays", select "A static Page"
10) Then select the new "Forum-Page" you just created.
11) Click "Save Changes"

12) Then go back to WP Dashboard and select "Appearance"
13) Then select Edit Menus
14) On the Menu Structure, change the link from the old "chat" page to the new Chat Page that you just created.
15) Click Save Menu

16) Refresh your website or press Control f5 to see the changes.

17) With the above setup, your main website or home page would direct to your wpForo Forum, and you can use your chat plugin, since I am assuming your chat plugin is also using the same WP User Table that wpForo is using.

18) I think those chat message errors that you are seeing is because WP is the core, wpForo is using the WP user table, and syncing to it, and since you initially turned your WP to wpForo, your chat plugin doesn't know how to "log" the chat sessions, and is turning them into slugs / posts.

Hope this helps. Good luck and God bless you. 🙂

Muhammad Umar Farooq
Posts: 32
Topic starter
(@pkheart)
Eminent Member
Joined: 4 years ago

@crisw Thanks for understanding and Support.   🙂 

You got my point but I want to use WPforo as stadalone (for better wide screen experience & short/better url as "forum-page" excludes)

is there any possibility to allow all URLs/pages while enabling " Turn WordPress to wpForo" 

1 Reply
CrisW
(@crisw)
Joined: 4 years ago

Reputable Member
Posts: 281
Posted by: pkheart

@crisw Thanks for understanding and Support.   🙂 

You got my point but I want to use WPforo as stadalone (for better wide screen experience & short/better url as "forum-page" excludes)

is there any possibility to allow all URLs/pages while enabling " Turn WordPress to wpForo" 

You are welcome @pkheart.

Now I am understanding the issue better. 🙂

I want to use WPforo as stadalone (for better wide screen experience & short/better url as "forum-page" excludes)

 

I noticed on your site that you are using 2019 WP Theme.

Have you considered changing your WP theme? And choose one which has an option for a wider screen?

One I can suggest is a theme called "StoreFront", (by Automattic - creators of WordPress), it has a full-width template, that I have used with other portals (I also tested how it looks with wpForo - it's wide enough for me! 🙂 ).

The wpForo Forum can work with that theme (using my long-winded suggestions above), and you can get the same end result.

You can try doing that while waiting for the wpForo update. 🙂

If you decide to use the WP theme "StoreFront" that you can download in the WP themes directory, just make sure you go to the WP "Widgets" area, and remove any WP widgets there, so that you can use the wpForo Widgets and take advantage of the Full-width template.

Or you can also just do a search on the WP theme directory, and search for "Full width template". I suggested "Storefront" because I've used it before, and I am wary of other themes conflicting with my simple setup.

Your website will look like a "standalone" forum, with my above suggestions, it can work.

I want to use WPforo as stadalone (for better wide screen experience & short/better url as "forum-page" excludes)

In the step-by-step suggestions that I typed above, specifically, 

Steps:
1) Go to Forum Settings
2) Under the "General Tab", UNCHECK the box that says: "Turn WordPress to wpForo"
3) Then click the blue "UPDATE OPTIONS" button at the bottom.

4) Then go to WP Dashboard, create a New WP Page call it "Forum-Page"

type the wpForo shortcode on this page

[wpforo]

click Publish.

And

6) Go to WP Dashboard
7) "Settings"
8) "Reading Settings"
9) Under "Your homepage displays", select "A static Page"
10) Then select the new "Forum-Page" you just created.
11) Click "Save Changes"

With my above suggestions, your users will not have to type

"https : // discuss . pkheart . com /vu/forum-page"

since Steps #6 to 11, takes care of the automatic redirection to your "homepage", and set by whatever WP page you want it to direct to.  

So, with my above suggestion, your user will be redirected to the "Static page" you created: 

https : // discuss . pkheart . com /vu/ 

I've personally used my above suggestions because all websites need to have their "Terms of Use", "Privacy Policy", GDPR pages, and if I turned my WP installation into a wpForo, all these pages would have to be created as "dated topics" under the "forum" folder, and if one is creating "evergreen" topics or articles, like "documentation", for example, and I don't want them dated, I would have to add a css to remove the dates on the forum, (which defeats the purpose of having a forum, in my opinion - forums should always be timestamped 🙂 ), that's why I keep them (WP and the Forum) separate and I've read up on wpForo documentation so that I understand it's many many possibilities for customizations, and also some of its limitations.  So that's why I suggested what I suggested.     

Hope this helps. Good luck and God bless you!

 

Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @pkheart,

we're preparing a new wpForo version, this problem will be solved in new version release. You just need to wait for a while. 

17 Replies
Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Posted by: @pkheart

@crisw Thanks for understanding and Support.   🙂 

You got my point but I want to use WPforo as stadalone (for better wide screen experience & short/better url as "forum-page" excludes)

is there any possibility to allow all URLs/pages while enabling " Turn WordPress to wpForo" 

Posted by: @sofy

Hi @pkheart,

we're preparing a new wpForo version, this problem will be solved in new version release. You just need to wait for a while. 

Many updates released but this issue is not fixed 🙁 

Kindly help me how to overcome on this issue. I want to use "Turn WordPress to wpForo" while allowing all pages.

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart

Please follow the  steps below:

1. Open the functions.php file in the wp-content/plugins/wpforo/wpf-includes/ folder

2. Find the function wpforo_urlencode 

3. Replace with the following one: 

function wpforo_urlencode($str){
if( !preg_match('#^(\#post-\d+|https?:)$#isu', $str)
&& !preg_match('#([\?\&][^\?\&/=\r\n]*=?[^\?\&/=\r\n]*)(?1)*$#isu', $str)
&& strpos($str, '~') === false
&& strpos($str, '*') === false
&& $str === urldecode($str) )
$str = urlencode($str);
return $str;
}

4. Navigate to Dashboard > Forums > Settings > General admin page, put the URL in "Exclude page URLs" section:

https://discuss.pkheart.com/vu/

The /* in the URL means that all the rest parts after the main part will be excluded as well. 

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Thanks a lot ! 🌼 

That's works for me perfectly !!! 👍 

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

All my additional wp pages are working fine but none of any forum post/topic working. "page can't be found" error appears (screen shot attached). only forum's main page displays.

 

( https://www.whichquery.com/vu )

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart

Please watch the video I've recorded for you: https://www.screencast.com/t/yq9bCoZe7

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Sorry to mention above that i was changed code to default in function.php file. So my site works on previous settings until solution found!

When ever i make change in function.php, all URLs are accessible but only forum main page is normal, all other forums posts/topics nothing is found "page can't be found" error appears.

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Please watch the video, May be helpful to understand the issue!

https://www.screencast.com/t/HXJWsdkrg4Uj

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart

I've already reported to the plugin developers about the issue. Please wait a bit. I'll update the topic once I get a response from them. 

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart,

4. Navigate to Dashboard > Forums > Settings > General admin page, put the URL in "Exclude page URLs" section:

https://discuss.pkheart.com/vu/  * 

the issue comes from the excluded URL you've added. It is wrong. 

The correct one is:

 https://discuss.pkheart.com/vu/chat/* 
Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

nope, all excluded URLs are accessible after applying code. but forum it self not accessible except main page.

https://www.screencast.com/t/HXJWsdkrg4Uj

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart

Please let us know have you changed the excluded URL as mentioned above? 

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

yes, And there is no issue remains about excluded URLs. The issue is after replacing the provided code, Forum itself not accessible but only main page is accessible ( https://www.whichquery.com/vu ). when click any post/topic error displays "Oops! that page can’t be found". video is already recorded for referrence.

https://www.screencast.com/t/HXJWsdkrg4Uj

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pkheart

Please send the admin login details to info[at]gvectors.com email address, to allow us to check the issue. 

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Shared on given email id !

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Thank you @pkheart !

Now please change the code chant the PHP code and let us know. Please don't change the admin accesses. We may need it. 

Muhammad Umar Farooq
(@pkheart)
Joined: 4 years ago

Eminent Member
Posts: 32

@sofy

Code added in Functions.php, Please check now/ Thanks

Share: