Notifications
Clear all

wpForo 1.x.x Permalinks fail, 404 errors for some (not all) tabs

13 Posts
4 Users
0 Likes
996 Views
Wilfried
Posts: 7
Topic starter
(@wilfried)
Active Member
Joined: 3 years ago

Hello,

I spent a lot of time getting links of categories and forums working correctly (but I failed).

But also the main 'tabs' Members , Recent Posts and My Profile don't work: they come up with an Object not found error (404).

This is the website I am working on 

But not all links provide a 404 (Logout and Add topic as a button work correctly)

The forum base url I have disabled the Wordpress front-end (using the checkbox 'Turn Wordpress to wpForo')

I didn't alter any slugs and I don't have other pages with similar titles as Members, Recent Posts, etcetera...

I also tried not to use the checkbox 'Turn Wordpress to wpForo', using a static page as Home forum as is explained over here

But this didn't help me out.

Please who can give me some clues? I notice the links Login and Register are preceded by ?foro= (I have to mention again I didn't alter any slugs...)

12 Replies
BlackRaz
Posts: 53
Admin
(@blackraz)
Contributor
Joined: 6 years ago

Hi Dear @wilfried .

First of all, make a sure on you apache server has enabled mod_rewrite module 

and follow this blog post   https://www.wpbeginner.com/wp-tutorials/how-to-fix-wordpress-posts-returning-404-error/

to enable the WordPress permalink system 

Reply
Wilfried
Posts: 7
Topic starter
(@wilfried)
Active Member
Joined: 3 years ago

Hi @BlackRaz,

mod_rewrite is enabled

saved permalinks again (didn't fix it)

.htacces file is also correct

Other clues?

Reply
Robert
Posts: 9707
Admin
(@robert)
Support Team
Joined: 6 years ago

You're using "Turn WordPress to wpForo" option in Dashboard > Forum > Settings > General admin page. Please disable it. And only enable  it when you read and understand what it means. If you want to display forum on home page use the regular options not this option. This option turns off all WordPress pages and plugins on website front-end. Please disable that option asap.

Reply
1 Reply
Wilfried
(@wilfried)
Joined: 3 years ago

Active Member
Posts: 7

@robert: I still have my questions... (as you can see I disabled the checkbox and have chosen a static page with the wpforo code: it still doesn't work...)

Reply
Wilfried
Posts: 7
Topic starter
(@wilfried)
Active Member
Joined: 3 years ago

@Robert: As I said/wrote I also tried this (the regular options) but it doesn't work either... 

 

And why when you use the regular option and link a static page to a page called forum (with [wpforo] code ) does wpforo create another page (called 'Forum page_on_front')??

Reply
5 Replies
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@wilfried,

First I recommend change the theme. This theme is designed for blog posts and it's too narrow for forum. Just change it to have a good view.

Second, the issue is a general issue not wpForo, and this is 100% related to your .htaccess file. I don't know what have you done with that file, but it doesn't work for sure. You can ask your hosting service for support or install a new WordPress website. Here are similar problems:

 

Posted by: @wilfried

And why when you use the regular option and link a static page to a page called forum (with [wpforo] code ) does wpforo create another page (called 'Forum page_on_front')??

The new page Forum page_on_front should be selected as home page in Dashboard > Settings > Reading admin page.

And please, navigate to Dashboard > Settings > Permalink, choose the "%postname%" option, click on the [Update options] button. Then navigate to Dashboard > Forums > Settings > General tab and click on the [Update options].

Reply
Wilfried
(@wilfried)
Joined: 3 years ago

Active Member
Posts: 7

@robert:

Thanks for answering

1) I changed the theme

2) This is the actual content from the ht access file:

# BEGIN WordPress
# The directives (lines) between `BEGIN WordPress` and `END WordPress` are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

3) Forum page_on_front was selected as you described Reading admin page...

4) Permalink where already selected as %postname%

Overall: I still don't get it why it doesn't work

Thanks for your patience.

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@wilfried,

How about other regular pages of your website. Do they work?

Have you contacted to your hosting service support, what hosting you use?

Have you checked the permissions of your .htaccess file (it should be 644)?

Reply
Wilfried
(@wilfried)
Joined: 3 years ago

Active Member
Posts: 7

@robert,

No problems with other websites (even other Wordpress driven ones).

My host doesn't know either.

Permissions are 644.

So, I don't know anymore

??

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@wilfried,

I'm not asking about your other websites. I'm asking about the current website. Do you have other pages in website? Do they work?

What means this "My host doesn't know either."? Please contact to your hosting service support and let them know about this issue. This is your WordPress configuration issue. This problem has nothing to do with wpForo.

 

Reply
Page 1 / 2
Share: