Notifications
Clear all

wpForo 1.x.x [Solved] New users default to usergroup admin

22 Posts
4 Users
0 Reactions
1,686 Views
Posts: 22
 Erik
Topic starter
(@erik)
Eminent Member
Joined: 8 years ago

New users default to usergroup admin (!) when created, how/where can I change that?

21 Replies
BlackRaz
Posts: 406
Admin
(@blackraz)
Contributor
Joined: 8 years ago

Hi Dear @erik

1) For WordPress default usergroup change please visit Dashboard > Settings > General and find selectbox labeled " New User Default Role "

2) For wpForo default usergroup change please visit Dashboard > Forums > Usergroups and find links labeled " Set as Default "

Posts: 22
 Erik
Topic starter
(@erik)
Eminent Member
Joined: 8 years ago

Hi @blackraz, thank you. I checked, there must be something wrong:

These are my settings:

Dashboard > Settings > General : default is 'subscriber'
Dashboard>Forums>Usergroups: default is 'registered'

Yet, when I create a new user in WP, the default forum usergroup is set to 'admin'

1 Reply
BlackRaz
Admin
(@blackraz)
Joined: 8 years ago

Contributor
Posts: 406

@erik

 visit Dashboard > Forums > Usergroups and scroll down to the end, and make a sure auto-synch setting is set like the attached example image

 

Posts: 22
 Erik
Topic starter
(@erik)
Eminent Member
Joined: 8 years ago

@blackraz , I don't have that table below usergroups...? See attached image

btw wpforo version is 1.7.1

 
8 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@erik,

Please, go to Dashboard> Forums > Debug > Tables admin page and make sure all tables are created correctly. If you see database errors, just click on the [Solve Database Problems] button.

Also, go to Dashboard > Forums > Settings > Features and enable "Role-Usergroup Synchronization" option.

 

 

Moderator
(@martin)
Joined: 8 years ago

Support Team
Posts: 988

@robert,

Also, please let us know, do you have user Role Editor?

Have you done any customization of user role permissions? 

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

@martin

No, we don't use User Role Editor. And as far as I know we didn't change role permissions, unless some plugin did without us knowing..

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

@robert 

No database errors

I have role-usergroup sychronization turned off, but that is on purpose.

I have a thought: is it possible, that when role-usergroup sychronization is disabled AND a new user is created in WP (by an admin, we have user-registration turned off), the script will simply take the first usergroup-ID (1) as default for forum usergroup? Which is admin. So unless you actively change that to a lower hierarchy before saving, the forum usergroup of the new user will be set to admin?

 

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@erik,

This option can be disabled without any issue. I just asked to enable for testing purpose. This option doesn't force you to be enabled for this purpose. It's totally independent.

Please let us know what registration form you use. I think the problem is in the registration form.

Also, let us know what wpForo Addons you use if there is any.

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

Hi @robert

We don't use any Addons currently

We only use the registration form in the backend, as only admins can add new users in our setup

I enabled Role-Usergroup Synchronization. I attached a screenshot of the lower section of the registration form. As you can see, the forum-usergroup is still set to admin ('beheerder'  in Dutch). WP user group = 'subscriber'

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@erik,

Ok, then let us login and debug the problem from backend. Please send admin login details to info[at]gvectors.com email address.

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

@robert

Done. 

One more thing: now that I have enabled Role-Usergroup Synchronization, I can see the following table in the lower end of 'forum-usergroups' > see attached screenshot

 

Robert
Posts: 10527
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @erik,

We just tested and didn't find such problem In both cases "UG Synch Enabled" and "UG Synch Disabled" the new registered user get "Registered" usergroup. There is no any problem.

5 Replies
 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

@robert

I'm afraid I'll have to disagree. I just tested by creating a new user with 'subscriber' - access to WP.

On the front-end this user is able to see all forums, including those that are set to be only accesible by admins...

 

 

Moderator
(@martin)
Joined: 8 years ago

Support Team
Posts: 988

@erik,

Here are our videos, all works just fine.

https://wpforo.com/wp-content/uploads/2020/03/email_confirm_register_test.mp4
https://wpforo.com/wp-content/uploads/2020/03/new_user_to_registered.mp4

Please share your videos. I think you do something irregular. 

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

Hi @martin

The video shows user registration from the frontend. We don't allow that, as I explained before.  You/Robert must have switched that on temporarily. I tried as well: FRom the frontend there is no problem.

However

Have you tried to create the new user from the backend as well? That is where the problem occurs.

regards,

Erik

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10527

@erik,

Ok, we'll check it tomorrow.

 

 Erik
(@erik)
Joined: 8 years ago

Eminent Member
Posts: 22

Thank you @robert , your help is much appreciated 🙂 Have a nice evening!

 

Page 1 / 2