Notifications
Clear all

[Solved] Google reCAPTCHA error: Your Answer was incorrect. Please try again.

7 Posts
3 Users
2 Likes
856 Views
Posts: 4
Topic starter
(@simonstone)
Active Member
Joined: 8 months ago

Hi there,

 

I am excited about this forum plugin and installed it with some configuration. But when I tried to register a new user, the Google reCAPTCHA always gives me error message at the up right corner: 

ERROR: Your Answer was incorrect. Please try again.

 

I checked my site key and secret key, making sure they are correct and correctly placed.
I checked the keys types and website address, and checked the documents about it, and make sure the excluded URIs in my LiteSpeed Cache.... 

I tried to register in Firefox, Vivaldi, Brave, Safari, etc. on my Desktop, and tried it on my Macbook and iPhone 14 Pro Max, after clearing the caches. 

 

All failed and give me the same error message.  

I searched all the error message in wpForo Support Forum, I didn't find any one has the same error message as mine. 

 

I hope someone could help me to resolve the problem. Many thanks.~

6 Replies
Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @simonstone,

First please exclude wpForo pages from your cache plugin. Find your cache plugin in this list and do the steps in the instruction: https://wpforo.com/community/faq/wpforo-and-cache-plugins/#post-37150

Second, make sure you don't have other reCAPTCHA plugins, only use wpForo reCAPTCHA.

5 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2577

@robert Cache & Page optimizers and Click/View source block and who knows what else he us using .....

 

<!-- Page optimized by LiteSpeed Cache @2023-09-09 14:39:52 -->
<!-- Page cached by LiteSpeed Cache 5.6 on 2023-09-09 14:39:52 -->
<!-- Guest Mode -->
<!-- QUIC.cloud UCSS loaded ✅ -->

(@simonstone)
Joined: 8 months ago

Active Member
Posts: 4

@robert Thanks for your reply!

 

Here is the screenshot of the page that I set up cache plugin - LiteSpeed. I mentioned it that I set it up before my first post.

(@simonstone)
Joined: 8 months ago

Active Member
Posts: 4

@robert I also attach a screenshot of my plugins list. Please let me know what plugin can use reCAPTCHA. Because I don't think any of them can use reCAPTCHA.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@simonstone,

First, please disable the cache plugin and check. Then other plugins.

BTW, contact LiteSpeed support and ask them why the forum pages are still cached. You should disable that cache for forum pages. If it doesn't work then LiteSpeed doesn't work either, contact them for further support.

(@simonstone)
Joined: 8 months ago

Active Member
Posts: 4

@robert 

Thank you for your instruction~

 

I tested and found it's the All-in-One Security Plugin. It has the reCAPTCHA feature that I set for the new user registration. I already turned it off and tested with wpForo forum plugin. And now it works very well~

Thanks again for the plugin and instructions~