Notifications
Clear all

[Solved] Guests can't see forums error 404

14 Posts
4 Users
0 Likes
884 Views
Posts: 9
Topic starter
(@joseemm96)
Active Member
Joined: 1 year ago

I was working in the style of my forum but seems like guests can access subforums getting an 404 error. If I'm logged as admin then I can see the topics without any issue

 

  • Is there a reason for this? 
13 Replies
dimalifragis
Posts: 2524
(@dimalifragis)
Famed Member
Joined: 4 years ago

Hi, i don't see any 404 anywhere.

Robert
Posts: 10475
Admin
(@robert)
Support Team
Joined: 8 years ago

@joseemm96,

I don't see 404 error either. In any case please navigate to Dashboard > wpForo > Overview admin page scroll down and click the [Hard Flush Permalinks] button.

1 Reply
(@joseemm96)
Joined: 1 year ago

Active Member
Posts: 9

@robert Hi Robert

 

Somehow got fixed. However, right at the top when I click the buttons to register or sig in (Iniciar sesíón) redirects to the homepage so new users can't register. I already hard flushed permalinks and changed the theme

Tutrix
Posts: 1181
(@tutrix)
Noble Member
Joined: 4 years ago

@joseemm96

your forum is a mix of wpForo version 1.x. x and the new version 2.0.8
have old wpForo files in your wordpress theme?

or you use the classic theme
try the 2022 theme

Posts: 9
Topic starter
(@joseemm96)
Active Member
Joined: 1 year ago

Now guests can't go to the register page or login page. I already checked the menu and seems fine with the right shortcode

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10475

@joseemm96,

Please navigate to Dashboard > wpForo > Overview admin page scroll down and click the [Hard Flush Permalinks] button.

Page 1 / 2