Notifications
Clear all

[Solved] Login and Register buttons

5 Posts
3 Users
3 Likes
409 Views
Posts: 41
Topic starter
(@engin)
Trusted Member
Joined: 1 year ago

Hi there,

With the Chrome browser, the Login and Register buttons are working for one Forum but not working for the other one and just bringing the same Forum page. 

On the other hand, Login or Register buttons work with Safari and the Fox browsers. What is wrong with Chrome or with my settings.? What am I missing?

PS. I just updated wpForo and I had this issue already before the update. 

Thanks

 

 

4 Replies
dimalifragis
Posts: 2577
(@dimalifragis)
Famed Member
Joined: 4 years ago

Remove Siteground optimizer, clear your browser cache and try again. And it would be better to stay away from SG optimizer and any optimizer (not needed with http2).

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

@engin,

First, install Really Simple SSL plugin to make sure you always use HTTPS protocol. Install the plugin, go to the plugin setting page and enable the SSL redirection.

Then exclude forum pages from your cache and optimizer plugins. wpForo does it itself and care about the forum cache. For the Siteground optimizer follow the instruction below, if the issue is not fixed just uninstall it, it doesn't help your forum, it stops all dynamic functions and makes your forum as a dead page.

 

SiteGround Optimizer plugin

  1. Please navigate in Dashboard to SG Optimizer > Caching admin page
  2. Scroll to Exclude URLs from Caching section and click the "pencil" button, enable it, and click the button again
  3. Insert the URL path(s) of your forum page(s) with wildcard [*] in the pop-up filed:
    /community/*
    /participant/*
    /sign-up/*
    /sign-in/*
    /change-password/*
  4. Save it and delete all caches.
1 Reply
(@engin)
Joined: 1 year ago

Trusted Member
Posts: 41

Thank you @robert, @dimalifragis 

I did exactly what you said. Before I deleted the SG optimizer I checked that all suggested URL paths with wildcard [*] were already there. ( I had 9 URLs). Nevertheless, I deleted the SG Optimizer Plugin and saved and deleted all caches. The Really Simple SSL plugin is installed. 

Guess what?

I still have the same issue. I can log in with Safari and Firefox but not with Chrome (from the forum)

Please note that the forum that I could Log in - Register is a Board (additional forum on another page)

Here is the link that the Login - Register buttons are not directing accordingly:

https://havacilarkonusuyor.com/community/

Thanks

 

Posts: 41
Topic starter
(@engin)
Trusted Member
Joined: 1 year ago

Thank you @robert@dimalifragis 

Just an update: When clearing the Chrome cache the "all time" option must be selected. Otherwise, the same issue keeps repeating. 

The problem is solved.