Notifications
Clear all

[Closed] Problem with translation

19 Posts
4 Users
0 Likes
585 Views
Posts: 241
Topic starter
(@berndg)
Reputable Member
Joined: 5 years ago

Hi,

I notice today that some translations are no longer displayed resp. replaced by English. When I check the translations in backend, however, everything there is unchanged and correct - and it has been correct so far.

The only thing I changed is to set up a second board for testing purposes. Can this be related, and if so, how do I get it to go away?

Thanks for your support,

Bernd

 
Topic Tags
18 Replies
BlackRaz
Posts: 406
Admin
(@blackraz)
Contributor
Joined: 7 years ago

Hi @berndg ,

I find the screenshot unclear. If you are referring to the post date and time information, WordPress handles the translation of the datetime information. To display the date and time correctly on the frontend, you should change the WordPress language to your preferred language.

8 Replies
(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@blackraz Thanks for caring. But why should I change the language? The language of this forum is German, and the problem ist that, although it was shown correct for years and was translated to German, single words are suddenly presented in English. 

It's not only here, but also here, for example (next screenshot). "Sticky" and "close" is English, the rest is still correct translated – as the other have been for at least two years. I did not change anything but installing a new board.

 

Yours, Bernd

BlackRaz
Admin
(@blackraz)
Joined: 7 years ago

Contributor
Posts: 406

@berndg Please take a look this FAQ Topic
https://wpforo.com/community/faq/how-to-translate/

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@blackraz Are you kidding me, do you not understand what I wrote or are you refusing to go deeper in the subject? I did NOT ask how to translate the WPForo language files.

Again: I translated everything years ago. It ran smoothly for at least more than two years. Then I set up a second board, the only thing I changed in a running system, maybe coincidentally or causal, but the only change to the running system.

Since, as I documented on the screenshots attached, single, obviously random words that had already been translated now show up untranslated.

Do you get the problem now?

Yours, Bernd

 

@Robert

BlackRaz
Admin
(@blackraz)
Joined: 7 years ago

Contributor
Posts: 406

@berndg 
I understand, but it seems that you translated everything before and saved those translation files in a folder that will be removed after each update. As a result, after the WordPress theme or plugin update, you lost all your translations.
And now you need to translate it again and save thooes files into the folder out of themes or plugins folder.
To prevent losing translations after theme or plugin updates, you should translate the content again and save those files outside of the themes or plugins folder. By storing the translation files in a safe location, they won't be affected by updates, ensuring that your translations remain intact even after WordPress theme or plugin updates.

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@blackraz This does definetely not explain why there are only a few words altered. And even updating WPForo (I was involved as Betatester) from 1.xx to 2.xx did not do what you describe.

And: There is no wrong translation in the language files, of course I checked this first before molesting the support. 

The language files look totally fine, there is no translation lost, none.

BlackRaz
Admin
(@blackraz)
Joined: 7 years ago

Contributor
Posts: 406

@berndg 
All WordPress plugin translation files are stored on the WordPress server. When you change the WordPress or plugin language, the WordPress core code requests and downloads the appropriate language .mo and .po files from the server. However, please note that your .mo and .po files may be upgraded. To prevent this upgrade process, you need to use LocoTranslate for completing and managing all translation phrases. Additionally, save the translation .mo and .po files outside the themes or plugins folder to prevent upgrading from the WordPress server and to preserve all your custom translated phrases.

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@blackraz Why do we have to start all over again and again? I know how to handle these files.

The problem, again, is, that only a few strings changes, and the only thing I changed was to install a new board for test reasons. Like these (bold the words that had been translated to german a long time before):

Vor 3 days  |  letzter beitrag: Vor 5 hours

These translations were made with the WPForo-tool for translations, they where correct before. 

But the single word "hour" or "hours" neither show up in the translation-tool of WPForo nor in Loco Translate. Nor does "day" oder "days" as a single word.

So where can I reach them and what is going on?

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@blackraz No idea after two weeks? Problem is still persisting and looks extremely unprofessionell.

Tutrix
Posts: 1266
(@tutrix)
Noble Member
Joined: 4 years ago

Posted by: @berndg

But the single word "hour" or "hours" neither show up in the translation-tool of WPForo nor in Loco Translate. Nor does "day" oder "days" as a single word.

and that doesn't work for you either?

If you didn't find some phrase you can add it as well. just use the [Add New] button.

 

3 Replies
(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@tutrix It's an English word in a German translated environment. Does not look professionell.

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1266

Posted by: @berndg

Does not look professionell.

Sorry, I don't understand

Example
You can add the English word "Day" using the [Add New] button and translate it to "Tag" (German)

What is unprofessional about it?

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@tutrix Maybe, that it will not show up in the place where it's needed?

Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

@berndg,

This is not wpForo problem so it may take even month to solve if you still use incorrect way to translate. First you should make sure the translation files are stored in update safe place. After installing wpForo and Logo translate plugin you should create/edit the language you want and copy the translation file to logo folder or to WordPress translation folder. 

Logo Translate plugin lets you copy the new language file to appropriate directories. The PM/MO files should be located in /wp-content/languages/plugins/ directory or in /wp-content/languages/loco/plugins/. Please make sure the po/mo files have wpforo- prefix, without this prefix they’ll not be processed.

If you don't keep them in a safe directory they will be removed and updated from wordpress.org with old ones and you'll have to translate them again.

4 Replies
(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@robert Thanks for caring. But what is incorrect? I translated everything inside WPForo at least two years ago, everything worked fine. The only thing I changed was installing a second board.

I did not use anything like Loco Translate etc. ever. Only during this conversation I had – for the first time – a look at the translation files with loco translate, without changing or saving anything. 

Looking at the pot-File with Loco does not show the problematic words either, like the translation tool inside WPForo does not. 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@berndg,

Have you used the PO/MO files to translate? What kind of translation you have sued. I assume you've only used the wpForo Phrase System in Dashboard > wpForo > Phrases admin page.

If so, each board creates its own phrase pack and you may need to migrate the translated phrase to new board as well. It's really hard to debug your issue by discussing here, so we may need to see the database tables to understand what's going on (if the translation was made using the phrase system not the po/mo files).

In any case I recommend install Loco Translate plugin and create a new translation file in an update-safe folder.

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@robert

Posted by: @robert

I assume you've only used the wpForo Phrase System in Dashboard > wpForo > Phrases admin page.

Correct, this is what I did, and it worked perfect. I used Loco only now for looking at the files, when the problem occurred, but not changing them with Loco. 

I took a look at the new board we are working on. Here, these translations are correct as they had been in the "old" board – where the German terms are replaced by the English terms. Looking at the translations with the wpForo Phrase System from the dashboard of the new board it seems that not any string has been translated (what I did not do until now anyway). 

If needed, I can activate the old access to our backend. Thanks again for caring!

 

Bernd

(@berndg)
Joined: 5 years ago

Reputable Member
Posts: 241

@robert

Hi Robert,

we decided today not to use the second board. Instead of deleting it immediately, I deactivated it first - and what happens: The translations in the first board are suddenly correct again, just as we entered them in the translation tables.

When I activate the board again, the wrong phrases are displayed again. When I deactivate it again, they are correct again and so on. This can't really be up to us now ...

If you want to have a look at this phenomenon yourself: I haven't deleted the board for now, let me know and I'll enable your support access again.

Thank you, Bernd