Notifications
Clear all

wpForo 1.x.x [Solved] RSS Feed showing as XML

3 Posts
2 Users
2 Likes
680 Views
mike46
Posts: 7
Topic starter
(@mike46)
Active Member
Joined: 2 years ago

Hi guys, just setting up a forum which is bare bones at the moment. Great plugin but like anything new it takes a bit of getting used to. With that in mind I apologise if this is a known issue, I can find it reported once 6 months ago but with no resolution.

Problem is that if I click on RSS feed forum or post I get an XML message with the following header.

"This XML file does not appear to have any style information associated with it. The document tree is shown below."

The body of the message contains code.

Now I know that I can switch off the RSS feed by toggling the button in "features" but seems a waste of a feature to do that.

So am I missing something, or is there a bug here?

Many thanks for a great plugin!

Topic Tags
2 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @somchai,

So am I missing something, or is there a bug here?

There is no bug here.

An RSS document (called “feed”, “web feed”,or “channel”) includes topic and post titles/links/excerpt publishing date and author’s name.

RSS feeds enable publishers to syndicate data automatically. A standard XML file format ensures compatibility with many different machines/programs. RSS feeds also benefit users who want to receive timely updates from the favorite forum or to aggregate data from many forums.

More info here: https://wpforo.com/docs/root/topics-posts/forum-topic-rss-feed/

1 Reply
mike46
(@mike46)
Joined: 2 years ago

Active Member
Posts: 7

@alvina many thanks. I'd forgotten about feed readers. I understand now sorry for troubling you.

 

Share: