Notifications
Clear all

wpForo 1.x.x [Solved] SEO setup

4 Posts
4 Users
5 Likes
1,302 Views
Swarup
Posts: 10
Topic starter
(@swarup)
Active Member
Joined: 2 years ago

Hi, my website is this: https://www.problemsheet.in . I am using this forum as a Question and Answer platform.

Question. Though wpForo adds SEO in this forum, the questions and answers from my website are not appearing in Google Searches.

  • Let me tell what I did with the Home page. I used the shortcode [wpforo item="forum"] in the Home page to make sure that users get to see the forum page in the first place.
  • As a need to it, I deleted the /%wpforo-home%/ custom link from wpForo navigation menu. Similar things were done with user profile and add topic.

Are these causing this trouble?

  • If yes, then what should I do? Actually I want the Home page to be the forum page as website requirement.
  • If no, please guide me.

I am a great fan of this wpForo plugin. I will be thankful if my problem is solved. Thank you!

Topic Tags
3 Replies
1 Reply
rravivarma5525
(@rravivarma5525)
Joined: 2 years ago

New Member
Posts: 1

I don’t know what happened to your site but I can suggest you that follow some google rules because if google loves automatically people love you
Put content simple and clean
No use of black hat SEO
Your site has no records

Try to use keywords based on your content
Hire our website app developers they will help you

Reply
dimalifragis
Posts: 1379
(@dimalifragis)
Noble Member
Joined: 2 years ago

Not sure why you did all that, i fail to understand.

So now you have a /community page with wpforo and also your home page with wpforo. Also registration and login go to /community.

If you only want a Forum, then turn Wordpress to wpforo, using the wpforo option in settings.

Also it is *IMPORTANT* to totally get rid of this Endurance cache plugin you have enabled.

Reply
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @swarup,

Question. Though wpForo adds SEO in this forum, the questions and answers from my website are not appearing in Google Searches.

Please navigate to Dashboard > Forums > Settings > Features Tab, and make sure these options are enabled:

  • Enable wpForo SEO for Meta Titles
  • Enable wpForo SEO for Meta Tags

Then go to Dashboard > Forums > Dashboard and click the [Delete all caches] button and check again.

Reply
Share: