Notifications
Clear all

wpForo 1.x.x [Solved] Sign up email Questions.

6 Posts
2 Users
3 Likes
466 Views
starman71
Posts: 53
Topic starter
(@starman71)
Trusted Member
Joined: 9 months ago

When you register to become a member, the email that arrives says it is from wordpress@ourdomain. How do we fix this so that it shows it is from our main email address or admin@ourdomain or registration@ourdomain? Also the sign up URL password set isn't a hot link. Is there a reason for that? How do we make it so it's an instant link rather than a link that has to be copied and pasted? Thanks for all your efforts! We love your forums!

wpForo Version
1.9.9
WordPress Version
5.9.2
7.4
5 Replies
dimalifragis
Posts: 1813
(@dimalifragis)
Noble Member
Joined: 3 years ago

Login/Register/Emails are ALL handled by Wordpress and not wpForo.

To solve your issue (a Wordpress issue and not a wpForo issue) read here:

https://wpforo.com/community/how-to-and-troubleshooting-2/registration-email-from-address-is-wordpressmydomain-com/#post-16186

Also you seem to use caching. And a poor one also (Endurance something).

<!--Generated by Endurance Page Cache-->

You MUST remove it, add some good one for your Wordpress and EXCLUDE the Forums from caching.

 

starman71
Posts: 53
Topic starter
(@starman71)
Trusted Member
Joined: 9 months ago

The hosting platform supplied that endurance option. It's not activated now. We installed wp Super Cache but not understanding where to disable the forums cache within it. Do we just add this in rejected URLs section as: forums\.php or is there some other way? Also posted this in their support forums. Thanks for the help if you know the answer.

1 Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1813

@starman71 

See what you must do, depending your forum URL change it if needed.

for me it is "/forums*" without the quotes of cource.

 

starman71
Posts: 53
Topic starter
(@starman71)
Trusted Member
Joined: 9 months ago

Thanks so much for your help! 👍 

May I also ask, if you know, how to make threads in the forum default to the first page? Right now when I click on a thread it jumps to the last post and if that is on the second page, that's the page it lands on. I wish to make it that all posts first default to the first page (although there might be times when I want it to default to the last post page). How can I adjust this, if you know.

starman71
Posts: 53
Topic starter
(@starman71)
Trusted Member
Joined: 9 months ago

BTW for anyone else reading this for the email issue showing up as wordpress@yourdomain.com, for me the easiest and fastest way to fix this was with the plugin CB Change Mail Sender if you don't want to have to change the code.