Notifications
Clear all

wpForo 1.x.x [Closed] Some member profile pages redirected to 404 page

10 Posts
3 Users
0 Reactions
425 Views
Posts: 61
Topic starter
(@seancallahan)
Estimable Member
Joined: 2 years ago

In the past two days, I've observed that certain members' profile pages have become inaccessible throwing 404 errors. An example is this user (link), who has been highly engaged in the community with hundreds of posts; however, attempting to access their profile now leads to a 404 page. I am currently using WPforo 2.17 and haven't made any changes to plugins. While I have upgraded to WordPress 6.4.1 and PHP version 8.1, I am skeptical that these updates would be the cause of the broken member profile URLs. Has anyone else encountered a similar problem, and if so, do you know of any solutions?

9 Replies
dimalifragis
Posts: 2612
(@dimalifragis)
Famed Member
Joined: 4 years ago

The link you provided is correctly returning  404, the profiles are at

/participant/userxxxx

 

1 Reply
(@seancallahan)
Joined: 2 years ago

Estimable Member
Posts: 61

@dimalifragis That user is still an active user and should have a profile like every other valid user. How does a good standing user go from /member/username to /404 ? Seems like a bug somewhere.

dimalifragis
Posts: 2612
(@dimalifragis)
Famed Member
Joined: 4 years ago

His profile is somehow REDIRECTED and results a 404.

Maybe you are using some other plugin for profiles. The wpForo profiles are at /participants as i told you.

5 Replies
(@seancallahan)
Joined: 2 years ago

Estimable Member
Posts: 61

@dimalifragis WPforo lets you set the permalink for certain pages in General Settings. It's worked fine for a year the way it was. Just recently started seeing some users profiles break where others have not.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612

@seancallahan You can't have such a page.

https://forums.fiskerati.com/maliblu/

All your profiles have a /member/namexxxx from what i see, the above doesn't.

What permalink you are talking about?

 

(@seancallahan)
Joined: 2 years ago

Estimable Member
Posts: 61

@dimalifragis Thanks, but there is a setting to change the profile URL in General Settings. 

That specific user 'maliblu' should have a profile page https://forums.fiskerati.com/member/maliblu/ but instead of showing the profile page it automatically redirects to https://forums.fiskerati.com/maliblu/ without 'member'. I've saw this happen yesterday for one other user too. However, when I'm logged in as the admin, and go to https://forums.fiskerati.com/member/maliblu/account/ it loads the profile. I checked the database and the user 'maliblu' is listed.

 

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612

@seancallahan

So you have set in General settings the /members to WHAT?

If you see as logged correctly, then it could be a caching issue.

(@seancallahan)
Joined: 2 years ago

Estimable Member
Posts: 61

@dimalifragis You mentioned it was called 'participant', I have it set as 'member'. See screenshot. It's almost like the profile page was deleted for this user and this user only, all the others I've tested work. The user exists and I can access the account as an admin, but when I click the profile button it goes to a 404 page. I have no idea how a profile page for a specific user could be deleted or hidden to render a 404 when the user is active.

Posts: 988
Moderator
(@martin)
Support Team
Joined: 8 years ago

Hi @seancallahan,

Try to edit the maliblu user and change the Nickname to something elese, e.g. to malibluuu. Save it, got to Dashboard > wpForo > Overview, scroll down, find the [Delete all caches] button and click it, then check then find and check the new URL of this user profile page.