Notifications
Clear all

wpForo 1.x.x Translation

12 Posts
4 Users
0 Likes
892 Views
pyue6299
Posts: 38
Topic starter
(@pyue6299)
Eminent Member
Joined: 2 years ago

Hi, after i added new po and mo file to the plugin file directory, will it be deleted after an update? if so, how can i aviod the po and mo files being deleted?

thanks!

11 Replies
Tutrix
Posts: 768
(@tutrix)
Prominent Member
Joined: 2 years ago

Hi @pyue6299

you can paste the .mo and .po files in the following update safe directory

wp-content / languages / plugins

Reply
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @pyue6299,

These two files should be located in /wp-content/languages/plugins/ directory or better use Loco Translate plugin to relocate the translation  files in a safe directory, e.g. in /wp-content/languages/loco/plugins/. Please make sure the po/mo files have wpforo- prefix, without this prefix you’ll they’ll not be processed.

More info here: https://wpforo.com/docs/root/translation/translate-using-pot-file/

Reply
4 Replies
pyue6299
(@pyue6299)
Joined: 2 years ago

Eminent Member
Posts: 38

@alvina @tutrix

I have translated wpforo & wpforo_poll with satisfactory result and saved the files to Langauge > Plugin to aviod file deletion while on updates.

I am translating wpforo_Attach and added to the same directories. But the translation does not take into effect. I then insert the files directly to the pugin folder, also not working.

Please advise.

Thanks!

Reply
Tutrix
(@tutrix)
Joined: 2 years ago

Prominent Member
Posts: 768
Posted by: @pyue6299

But the translation does not take into effect. I then insert the files directly to the pugin folder, also not working.

in which language do you translate

are you using the correct prefix for your language?

Example for German

wpforo_attach-de_DE.mo
wpforo_attach-de_DE.po

Reply
pyue6299
(@pyue6299)
Joined: 2 years ago

Eminent Member
Posts: 38

@tutrix Traditional Chinese. Please see the file name in the attached image:

wpforo_attach-zh_TW.mo

wpforo_attach-zh_TW.po

Reply
pyue6299
(@pyue6299)
Joined: 2 years ago

Eminent Member
Posts: 38

@tutrix

Any update thanks!

Reply
Tutrix
Posts: 768
(@tutrix)
Prominent Member
Joined: 2 years ago

@pyue6299

sorry I don't know why the translation doesn't work for you

try using Loco Translate as suggested by Alvina

or with Quick Translation – Phrases

Reply
4 Replies
pyue6299
(@pyue6299)
Joined: 2 years ago

Eminent Member
Posts: 38

@tutrix

i tried both the Loco and Quick Translation plugin. None have helped. And i discovered one thing, your wpforo advanced attachment just does not detect the change of language. All my other wpforo extension can change different language but just your advanced attachment. See the attached screenshot for further details. The extension just can't detect any change on language.

Reply
Tutrix
(@tutrix)
Joined: 2 years ago

Prominent Member
Posts: 768

@pyue6299

try

Forums > Settings > Addons > Attachments > Front-end Phrases

Reply
pyue6299
(@pyue6299)
Joined: 2 years ago

Eminent Member
Posts: 38

@tutrix

I tried to amend My Media in Forums > Settings > Addons > Attachments > Front-end Phrases, but after i clicked SAVE and refresh the page, the amendment does not update and get reflected.

Please advise.

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@pyue6299,

Please navigate to Dashboard > Forums > Settings > Features Tab and disable the Options Cache option. Then try changing the attachments settings again.

Reply
Share: