Notifications
Clear all

wpForo 1.x.x [Solved] Translation issue

13 Posts
2 Users
1 Likes
836 Views
airammontessori
Posts: 16
Topic starter
(@airammontessori)
Eminent Member
Joined: 1 year ago

Hi,

The site is in French. We just migrated our forum from bbPress to WPForo. The forum looks good, thanks for this great plugin.

On the page linked to my post, you can see that there's some WPForo strings in French and others in English. The French translation file is all right, I can edit it with Loco. The problem is that the "Phrases" loaded by default with the installation of WPForo are overwriting the French translation file.

Example: on the page, you can see "Recently viewed by users". This string is correctly translated in the French translation file but because this string is present in the "Phrases" section, I have to re-edit it manually there to display it in French which doesn't seem very efficient.

And I can't delete any existing phrases, I can only edit them. There's no "delete" option in this section, not sure if that's normal.

Is there something I'm missing? How can I delete all these phrases so that they aren't conflicting with my French translation file?

Thanks.

12 Replies
Chris
Posts: 2405
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @airammontessori,

Posted by: @airammontessori

And I can't delete any existing phrases, I can only edit them. There's no "delete" option in this section, not sure if that's normal.

No, that's normal that you can't delete the existing phrases.

The first reason may be from the location of the .Mo and .Po files. Please read the below Documentation, specially the 6. Add a new language part.

https://localise.biz/wordpress/plugin/beginners

The second reason may be from the cache. If you have a cache plugin, exclude wpForo from the cache plugin and clean the website cache. Check the below topic about cache.

https://wpforo.com/community/faq/wpforo-and-cache-plugins/

The third reason may be from the phrases.

Find a phrase which is not translated with Loco, go to Dashboard > Forums > Phrases, find that Phrase, edit it and check the original and the translation, both of them must be same even, if there is any different between them(space, comma) change the translation to same as the original,  after that clean the caches by pressing Dellete All Caches button from Dashboard > Forums > Dashboard.

4 Replies
airammontessori
(@airammontessori)
Joined: 1 year ago

Eminent Member
Posts: 16

@chris Sorry I've tested the 3 options and I can't fix the problem.

Loco works great with all the other plugins. .mo and .po files are in the right WpForo folder (there are in this folder by default).

I've cleaned all caches, put some exclusions in Fastest Cache.

Phrases are there by default, I haven't touched them. You can check by yourself, I only have the "edit" options and not the "delete" option which would gladly help me. How do I hard erase thoses phrases? (FTP, DB?)

What are my options?

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@airammontessori,

Follow these steps`

1. go to \wp-content\plugins\wpforo\wpf-admin\xml\ and find english.xml file.

2. Make a copy of the file and rename the copy file to english2.xml

3. Edit english2.xml with a text editor and find the below code(it's at the top 2 line)

<language name="MASTER" language="English" encoding="UTF-8" version="1.0.0" code="en">

 4. Rename English to English2 and save the file like the below one.

<language name="MASTER" language="English2" encoding="UTF-8" version="1.0.0" code="en">

5. Go to Dashboard > Forums > Settings Tab, find XML Based Language option and press Add New Button.

6. Add english2.xml file and select it in XML Based Language select bar

7. Press Update Options Button and go to your website

8. Press Twice CTRL + F5 in your website.

After these Loco Translates must work.

airammontessori
(@airammontessori)
Joined: 1 year ago

Eminent Member
Posts: 16

@chris Thanks for your time. I did everything you said and still no luck ;(. I even erased those 2 xml files from FTP for testing purposes.

I still have some untranslated strings like "Previous Topic" or "Next topic". Yet those strings are properly translated in the .mo and .po files ...

I've emptied all caches before writing this post.

You can check it there: https://www.formationairammontessori.com/d/faq/formation-montessori-suffit-elle-pour-exercer/

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@airammontessori

Go to Dashboard > Loco Translate > Plugins > wpforo and press copy on the language you need

1. Choose a language > Enable WordPress language and choose the needed language

2. Choose a location > System(languages/plugins/wpforo-**_**.po)

3. Template Option > Copy target translations from "**_**"

Then press Start Translating button. 

In the new tab, press sync button.

And translate the missing phrases.

airammontessori
Posts: 16
Topic starter
(@airammontessori)
Eminent Member
Joined: 1 year ago

It says "wpforo-fr_FR.po" already exists in this folder ;).

If I delete the file, I'm afraid I have to retranslate ALL strings which wouldn't be efficient as lots of them are already translated AND working on the front-office.

Any suggestion? 😉

5 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@airammontessori,

The location is system?

airammontessori
(@airammontessori)
Joined: 1 year ago

Eminent Member
Posts: 16

@chris Yes, please see screenshot attached. The file installed there by default with WPForo installation apparently.

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@airammontessori,

Please send admin credential of the website to info[at]gvectors.com

Our Developer will check your website and fix the issue. 

airammontessori
(@airammontessori)
Joined: 1 year ago

Eminent Member
Posts: 16

@chris Send. Thanks Chris.

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@airammontessori,

We have checked your website and saw that you didn't synchronize the French translation which is located in system.

You missed this part`

Posted by: @chris

Then press Start Translating button. 

Which I have mention above

I have synchronized French located in system and translated an English word to French, which worked correctly.

Now your French Translation located in system is completed only 57%

After translating the words, go to Dashboard > Forums > Dashboard and click on Delete Phrase Cache button. 

 

airammontessori
Posts: 16
Topic starter
(@airammontessori)
Eminent Member
Joined: 1 year ago

Hi @chris, I hadn't had the chance to thank you for looking into this. I just checked the newly created translation file. Thanks.