Notifications
Clear all

wpForo 1.x.x wpForo making site slow and adding no cache header to stop SG optimizer for caching

22 Posts
5 Users
1 Likes
1,444 Views
ManojK365
Posts: 13
Topic starter
(@manojk365)
Active Member
Joined: 2 years ago
After deactivating the plugin, my site working fine. Added Form URLs in SG excluded list also but not working. Adding URL not stopping by wpForo to add a header to stop dynamic caching. 
 
What is the solution?
 
 
x-proxy-cache : MISS
 
cache-control: no-store, no-cache, must-revalidate
 
 
Response Version - HTTP/2.0
alt-svc
h3-27=":443"; ma=86400, h3-28=":443"; 
ma=86400, h3-29=":443"; ma=86400
cache-control
no-store, no-cache, must-revalidate
cf-cache-status
DYNAMIC
cf-railgun
404a4c45bb stream 0.000000 0210 0dda
cf-ray
5bf8567d286ac97d-SEA
cf-request-id
046f1462390000c97d3116b200000001
content-encoding
br
content-type
text/html; charset=UTF-8
date
Sat, 08 Aug 2020 09:51:17 GMT
expect-ct
max-age=604800, 
report-uri=
"https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
expires
Thu, 19 Nov 1981 08:52:00 GMT
host-header
6b7412fb82ca5edfd0917e3957f05d89
link
< https://www.manojk365.com/wp-json/>;  
rel="https://api.w.org/",
< https://wp.me/PbWamw-2>; rel=shortlink
pragma
no-cache
server
cloudflare
set-cookie
__cfduid=d471ab8fc36cedf9f57509e847c1684461596880276; 
expires=Mon, 07-Sep-20 09:51:16 GMT; path=/;
domain=.manojk365.com; HttpOnly; SameSite=Lax; Secure
set-cookie
PHPSESSID=62a2218ccc92c89fe56e5974c6820e62; path=/
status
200
vary
Accept-Encoding
vary
“Accept-Encoding”,User-Agent
x-cache-enabled
True
x-httpd
1
x-proxy-cache
MISS
x-proxy-cache-info
0 NC:000000 UP:1
Request Version - HTTP/2.0
:authority
www.manojk365.com
:method
GET
:path
/
:scheme
https
accept
text/html,application/xhtml+xml,
application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,
application/signed-exchange;v=b3
accept-encoding
gzip, deflate, br
accept-language
en-US,en;q=0.9
upgrade-insecure-requests
1
user-agent
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 
(KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
21 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @manojk365,

Please follow this FAQ topic: https://wpforo.com/community/faq/forum-is-slow/

Reply
2 Replies
ManojK365
(@manojk365)
Joined: 2 years ago

Active Member
Posts: 13

1. Forum Layout is  Simplified 

2. Database is InnoDB

3. Indexes are ok, no error

4. wpForo Cache are ok

 

but still, it's slow and SG Optimizer is not able to cache, I don't know why this is adding a header to stop caching by SG. 

 

 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@manojk365,

This issue may come from the PHP session wpForo initiates. The session will be removed soon in future releases.

1. At the moment please try this: https://wpforo.com/community/how-to-and-troubleshooting-2/phpsessid-placed-by-wpforo-is-preventing-caching-on-the-rest-of-the-website/#post-44636

2. Then disable the addons mentioned in this post: https://wpforo.com/community/how-to-and-troubleshooting-2/phpsessid-placed-by-wpforo-is-preventing-caching-on-the-rest-of-the-website/#post-44697

3. Then delete all caches, logout and test it again. It's better to delete all cookies of the browser before checking, or use a new browser.

Reply
ManojK365
Posts: 13
Topic starter
(@manojk365)
Active Member
Joined: 2 years ago

After replacing the above code also, still missing the caching. Not using other wpforo plugins. 

public_html > wp-content > plugins > wpforo > wpf-includes > functions.php

function wpforo_is_session_started(){
// if ( php_sapi_name() !== 'cli' ) {
// if ( version_compare(phpversion(), '5.4.0', '>=') ) {
// return session_status() === PHP_SESSION_ACTIVE ? TRUE : FALSE;
// } else {
// return session_id() === '' ? FALSE : TRUE;
// }
// }
return FALSE;
}
Reply
2 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@manojk365,

And please deactivate the mentioned wpForo addons if you have.

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

Before the checking delete all cookies of your browser, lose it and open it again.

Also, leave a direct URL to your website to allow us check it.

Reply
ManojK365
Posts: 13
Topic starter
(@manojk365)
Active Member
Joined: 2 years ago

Already used in InPrivate mode. 

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@manojk365,

Don't use the private mode, it'll not allow to cache some browsers. Just use a regular mode, but delete all cookies before using. Also, delete all caches and purge JS/CSS minifications. Don't forget close/open  the browser. At the moment we see there is no PHPSESSION cookie on your website, so it's probably getting fixed.

Reply
ManojK365
Posts: 13
Topic starter
(@manojk365)
Active Member
Joined: 2 years ago

https://www.staging9.manojk365.com/

 

I am using the staging site to resolve the issue before enabling the plugin in my production site. 

Reply
Page 1 / 3